We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40206
    • 13 Posts
    Hi, I have a problem. After mapping the domain to the subfolder /MODX2/ and editing the file core/config/config.core.php (the $modx_manager_url, $modx_connectors_url and $modx_base_url was editing to /), also the .htaccess. The Website works correctly, but I can't start the manager. I get the massages:
    What can I do? Thank you

    Warning: include_once(/mnt/webk/c3/33/51037133/htdocs/core/model/modx/modx.class.php) [function.include-once]: failed to open stream: No such file or directory in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 50

    Warning: include_once() [function.include]: Failed opening '/mnt/webk/c3/33/51037133/htdocs/core/model/modx/modx.class.php' for inclusion (include_path='.:/opt/RZphp52/includes') in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 50

    Warning: include(/mnt/webk/c3/33/51037133/htdocs/core/error/unavailable.include.php) [function.include]: failed to open stream: No such file or directory in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 51

    Warning: include() [function.include]: Failed opening '/mnt/webk/c3/33/51037133/htdocs/core/error/unavailable.include.php' for inclusion (include_path='.:/opt/RZphp52/includes') in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 51
    Site temporarily unavailable!
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Did you also edit the core.config.php files, one in the installation root, one in /manager/, one in /connectors/ ?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 40206
        • 13 Posts
        ....
        If I rename the content of config.core.php to <?php
        define('MODX_CORE_PATH', '/mnt/webk/c3/33/51037133/htdocs/MODX2/core/');
        define('MODX_CONFIG_KEY', 'config');
        ?>

        (before I delete the /MODX2 in this file for testing)
        the manager starts, but without anything, look at the attachment

        Please help me, its very important for me today! Thank you!
          • 40206
          • 13 Posts
          I have edited all config.core.php Files. There is no "MODX2", for example the manager config.core.php:

          <?php
          define('MODX_CORE_PATH', '/mnt/webk/c3/33/51037133/htdocs/core/');
          define('MODX_CONFIG_KEY', 'config');
          ?>

          Also I have the MODX2 removed in alle config.core.php, but the result is the error message (first post)
            • 40206
            • 13 Posts
            I don't know, the paths where do they come? I have all pathes in the config.core.php edited?

            Warning: include_once(/mnt/webk/c3/33/51037133/htdocs/core/model/modx/modx.class.php) [function.include-once]: failed to open stream: No such file or directory in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 50

            Warning: include_once() [function.include]: Failed opening '/mnt/webk/c3/33/51037133/htdocs/core/model/modx/modx.class.php' for inclusion (include_path='.:/opt/RZphp52/includes') in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 50

            Warning: include(/mnt/webk/c3/33/51037133/htdocs/core/error/unavailable.include.php) [function.include]: failed to open stream: No such file or directory in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 51

            Warning: include() [function.include]: Failed opening '/mnt/webk/c3/33/51037133/htdocs/core/error/unavailable.include.php' for inclusion (include_path='.:/opt/RZphp52/includes') in /mnt/web6/e0/33/51037133/htdocs/MODX2/manager/index.php on line 51
            Site temporarily unavailable!
              • 39344
              • 23 Posts
              Hi brownie04,

              when moving sites around i just re-run the MODX setup. Maybe the folder /setup is already gone in your installation. In this case you have to extract it from the zip and upload it again.

              Most of the time this resolves all issues with paths...

              Make a backup frst in case something gets messed up, just in case!

              You have read and followed the relevant parts of the documentation found at http://rtfm.modx.com/display/revolution20/Moving+Your+Site+to+a+New+Server i assume?




              Greetings from Stuttgart
              Harde
                • 40206
                • 13 Posts
                Quote from: harde_76 at Jun 14, 2013, 11:56 AM
                Hi brownie04,

                when moving sites around i just re-run the MODX setup. Maybe the folder /setup is already gone in your installation. In this case you have to extract it from the zip and upload it again.

                Most of the time this resolves all issues with paths...

                Make a backup frst in case something gets messed up, just in case!

                You have read and followed the relevant parts of the documentation found at http://rtfm.modx.com/display/revolution20/Moving+Your+Site+to+a+New+Server i assume?




                Greetings from Stuttgart
                Harde
                  • 40206
                  • 13 Posts
                  I done a update from MODX, the system said it´s all o.k.. I can start the manager - but its empty. No resources... Had everyone the same problem??? What can I do?
                    • 38705
                    • 101 Posts
                    I would suggest that you clear the cache and flush all sessions, thus logging you out from the manager.
                    Then manualy delete the contents of the core/cache folder (do not delete the actual folder)

                    also you can check the following settings in your database table modx_system_settings:
                    compress_css = 0
                    compress_js = 0

                    if those settings are set to 1 the manager tries to compress css and js, which can make the manager produce empty pages...
                      Addict since 2012....
                      • 40206
                      • 13 Posts
                      Hallo mintnl, thank you. I have done all this things, but the manager shows me no data, look at the screenshot. All caches are empty, the setting from compress_css = 0 and compress_js = 0.

                      The website can be opened from the manager, it works correctly!

                      Its very important for me to solve this problem, any idea? For the solution-answer I will pay 100 € for you, if you want.