We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21414
    • 41 Posts
    Having a strange problem within a modxcloud developer cloud.

    I duplicated my web context, and updated the context settings to allow access to the site, then cleared the sites cache, and flushed the permissions.

    Afterwards when I tried to view the resources within the "front end" the site failed to load with a "this link appears to be broken" error.

    I've gone all through my permissions and can't find a reason why the page wont load there, but if I move it to the main "web" context it loads fine.

    using modx version 2.2.8pl

    attached screenshots of my context permission settings & the error

      • 32699 ☆ A M B ☆
      • 427 Posts
      did you change the three system settings:

      "For MODX to properly function, you'll also want to define the base_url (eg "/"), site_url (eg http://sub.domain.com/) and site_start (eg 15 for resource 15) setting"

      I'd also look at this: http://rtfm.modx.com/display/ADDON/ContextRouter

      What defines the new context: domain name, subdomain, language?
        Get your copy of MODX Revolution Building the Web Your Way http://www.sanitypress.com/books/modx-revolution-building-the-web-your-way.html

        Check out my MODX || xPDO resources here: http://www.shawnwilkerson.com