We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37619
    • 79 Posts
    I'm using MODX Revolution 2.2.2

    Hello Fellow MODXers!

    I'm in a bit of a pickle here... I have just moved a MODX site from server A to server B, and the site itself is working as it should. I can get in the manager and navigate to any page I want, I can download, update, install and re-install extras without and I can edit and save chunks, snippets, TVs, what-have-you... except for Resources.

    For whatever reason, since I've moved the site to the new server, the only way my resources are accessible are through the Quick Update; at least the Resources Tree is showing all pages. But when I click on a resource to edit it, it gives me a 500 Server Error.

    The first thing I did was to reset the cache by deleting the cache folder and creating a new one with the same permissions (755). That did nothing. After doing some research, I found out that it could be TinyMCE or Wayfinder. So I removed those and re-installed them, but the issue persists. Upon further research, I found out that it might be something to do with the server's PHP Memory Limit. Ours is set to 128MB, so that really shouldn't be a problem either.

    Finally, we've moved 100+ Revo sites from server A to server B, and only this one has that problem. Does anyone know what else I could do to fix this issue?

    Thanks!
    jm

    This question has been answered by jmbuytaert. See the first response.

      Jean-Marc Buytaert (@jmbuytaert)

      MODX truly is the greatest thing that's ever happened to the Internet.
      • 18373 ☆ A M B ☆
      • 3,141 Posts
      First of all, find the server error log. If that's not your first step you're wasting time wink

      My guess is that one of the Extras you are using has an old path hardcoded somewhere. Which one? The server error log should give you a good idea..
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 37619
        • 79 Posts
        I didn't think it'd be a server error because both the site and the manager are working perfectly fine except for that one issue. Now that I look back at what I just wrote, it IS an 500 server error... sooo... yea... you're right smiley I'll check that.

        Thanks Mark!
          Jean-Marc Buytaert (@jmbuytaert)

          MODX truly is the greatest thing that's ever happened to the Internet.
          • 509
          • 93 Posts
          Hi,

          Error 500 !!!

          I tried to upgrade with last version on 2 websites using MODx REVO and the 2 are now KO with a 500 error sad
          What's wrong?

          There is a big problem with this new update
          Now everything is ko
          • discuss.answer
            • 37619
            • 79 Posts
            So as it turns out, after looking at the server error log (thank you Mark), I noticed this error that popped up a lot:
            mod_fcgid: stderr: PHP Fatal error:  Cannot redeclare class modTemplateVarInputRenderText
            Upon doing some research regarding that error, I found a post (https://forums.modx.com/thread/73238/easing-the-move-to-a-new-server-and-re-running-setup) stating that it could be the TVs using a Custom TV Type that might not exist anymore.

            So I went through all my TVs and found 2 things that were funky:

            1) 2 of my TVs were set as Radio Options (so far so good) but were calling Evo chunks
            {{chunk}}

            2) 2 other TVs had a TV Type of textareamini, so I changed those to textarea, cleared the cache, and voila, now it works

            NOTE: I also noticed that those TVs were italicized, and became normal once I had fixed them. That might be helpful in case you have a lot of TVs and don't want to go through all of them.

            Thank you Mark for pointing me in the right direction!
              Jean-Marc Buytaert (@jmbuytaert)

              MODX truly is the greatest thing that's ever happened to the Internet.
              • 15877
              • 55 Posts
              Had the same error with a different cause.
              It was due to Tiny MCE.
              A quick way to check this is to uninstall Tiny MCE and then try to edit a page. If it works, the problem is not with the TVs.