We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37114
    • 5 Posts
    Environment:
    Operating System: Linux - CentOS
    PHP Version 5.3.3
    Server API: CGI/FastCGI
    MySQL: 5.0.77
    Panel: Plesk 10.3
    MODX: 2.2.6 Trad
    Addons: wayfinder, versionx, tinymce

    Situation:
    I have a simple site running on a subdomain of our server, and it all works fine. The site uses wayfinder for navigation, and pages pulls in some HTML content from a couple of rich text TVs. Very straightforward.

    To move this site into production I have set up another domain on the same server. I then copied over the files from the sudomain to the new domain/folder, re-ran setup on the new domain, and logged into the manager (all as expected).

    The problem occurs when I try to access the public website. I get the following error:

    Fatal error: Class 'modFileMediaSource_mysql' not found in /var/www/vhosts/xxx.org/xxy.org/core/xpdo/xpdo.class.php on line 761

    Assumptions:

    • Apache seems to be serving pages correctly - simple html files and some modx rendered html get served correctly
    • MODX Setup suggests connection to db is working correctly

    What Ive discovered:

    • Simple modx pages display just fine
    • If I comment out the calls to wayfinder, and the calls to the TVs, the rest of the page content displays fine (things like pagetitles and content display correctly).


    So my question is this; can any of you lovely people suggest any likely candidates for what is wrong, or where I should be looking to find the problem?

    TIA,
    Jon
    [ed. note: brookes last edited this post 13 years, 6 months ago.]
      • 37114
      • 5 Posts
      Also tried:
      Re-installing from the zip file, and then restoring the database from a backup, and then running setup/upgrade again. This made no difference. Same error.



        • 28042 ☆ A M B ☆
        • 24,524 Posts
        I seem to recall something about looking for wrong paths in the database in fields dealing with namespaces.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 37114
          • 5 Posts
          Hi Susan,

          Thanks for the idea. I had a look in the _namespaces table (amongst others). It contains the following, which Im thinking looks okay:

          core			{core_path}					{assets_path}
          tinymce		{core_path}components/tinymce/	
          versionx		{core_path}components/versionx/	
          wayfinder		{core_path}components/wayfinder/	
          


          After more searching I checked the install log and found these messages:

          2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/beada694127e00c7caacf4a6e0e1c2cb/0/ to /var/www/vhosts/xxx.org/xxy.org.uk/index.php
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/beada694127e00c7caacf4a6e0e1c2cb/1/ to /var/www/vhosts/xxx.org/xxy.org.uk/ht.access
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/0/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/assets
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/1/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/controllers
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/2/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/templates
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/3/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/min
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/4/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/ht.access
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/5/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/cache.manifest.php
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not copy /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/modContext/0d7cb0d8ebad451b893bcbdea7e63f07/6/ to /var/www/vhosts/xxx.org/xxy.org.uk/manager/index.php
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/ba2b54719b37ebe8e83826d092a5c9bb/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/bbf13f2d73102563bcb0c0f34cd3c128/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/22b0bc8a6c13bf5c5d8d30264cbae4d6/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/2ad7b155e89236583fb9bec7a54614d1/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/30d32c53dad267ac6ea7fa976735cf0a/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/5369d27b37c905f2be49a586fe2c8864/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/5e169ae4a9ff6c08310fab5e7b8e1e4e/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/a148882e26c4e4d3d41f07e707e1f728/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/d83ae06215688224c5abb5c1f2103485/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/609dba858be64c0152d125213d16bf67/ to /var/www/vhosts/xxx.org/xxy.org.uk/connectors/
          [2013-03-25 15:38:56] (ERROR @ /setup/index.php) Could not install files from /var/www/vhosts/xxx.org/xxy.org.uk/core/packages/core/xPDOFileVehicle/fa8a70bb8b4cabeac99edd72a63781c0/ 


          Nothing was flagged during the setup procedure, but these look suspicious as they relate to core/xPDOFileVehicle/

          I checked ownership and permission on the connectors folder and that seems fine. Would setup throw these errors (when doing an upgrade) if the files already exist? The output (above) was the entirety of the install log. I would have expected more of these errors if they are thrown every time a file already existed?

            • 37114
            • 5 Posts
            So in case anyone else comes across this problem Ill post the work-around I found. I say work-around as I dont feel that I really found the actual cause.


            I ended up reinstalling MODX from scratch and rebuilding the site piece by piece.

            It all worked nicely up until this code was put in place:
            [[*right-column-links:notempty=`[[$right-column-section]]`]]


            I read various posts saying that their were (or had been) issues with the notempty filter, so I replaced this code with a snippet to do the same thing.

            It was still throwing the same error!

            Then I made all of the code pulling in TV content non-caching. This 'fixed' it.... o_O

            So it works, but at the cost of losing some of the caching.

            I still suspect that it is a conflict with the Apache config in some way. Perhaps a conflict with Apache caching, is that still an issue for MODX?
              • 37114
              • 5 Posts
              Although, it could be related to bug in 2.2.6...

              I saw the following in the changelog for 2.2.7. Unfortunately it doesn’t seem to mention which bug it was related to:

              MODX Revolution 2.2.7-pl (April 9, 2013)
              ====================================
              ...
              ...
              - [#9738] Prevent working context overriding user settings
              - Fix error getting MediaSource table classes on cached Resources
              - [#9368][#9437] Fix modProcessorResponse->isError()
              ...
              ...

              When I upgrade to 2.2.7 Ill let you know if it fixes it.