We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25054
    • 8 Posts
    My error log is reporting that "[image path] does not exist in file 'phpthumb.class.php' on line 3647" every time I do anything within the manager. I mean, all I have to do is, say, refresh the error log and I get another instance of this error. The actual error message is a lot longer (I'll post it after explaining), and is caused by phpThumbOf.

    Here's my setup:

    FreeBSD 8.2-STABLE
    Apache/2.2.23
    PHP Version 5.3.18
    MODX Revolution 2.2.6-pl (traditional)

    I'm using different contexts and media sources. MODx is installed at /usr/www/users/username/cms but I use this folder only to manage my websites, those are hosted in other folders.

    Contexts:
    mgr : hosted at default location
    web : hosted at default location - won't be using it for public websites
    site1 : hosted at /usr/www/users/username/site1 (using virtual hosts)

    site1 uses it's own media source where I host it's images, templates etc. Here are some settings:

    site1 context:
    base_path - /usr/www/users/username/site1
    base_url - /
    phpthumbof.cache_path - /usr/www/users/username/site1/assets/components/phpthumbof/cache/
    phpthumbof.cache_url - assets/components/phpthumbof/cache/


    site1 media source:
    basePath - /usr/www/users/username/site1/assets/
    basePathRelative - No
    baseUrl - assets/
    baseUrlRelative - No


    I have an "Illustration" TV (type image), used by an "Article" template in site1. This template uses GetResources to list recent articles with a thumbnail of their illustrations, generated by: [[+tv.Illustration:phpthumbof=`w=150&h=75&zc=1`]]

    Ok, thats what's causing the manager errors, I just don't know how. The website renders just fine, no errors are thrown from the the front end. The Illustration, hosted at /usr/www/users/username/site1/assets/images/stories is processed and a thumbnail is generated and cached. But whenever I do anything at the manager, it acts as if it were trying to render that thumbnail, and since it uses the wrong context (mgr), wrong media source, it can't find the original image to make a thumbnail of, it looks for it at /usr/www/users/username/cms/assets/images/stories. How can a manager action generate erros from a front end template? Illustration TV values are like this "images/stories/image_name.jpg"

    Can anyone, please show me a light? I've tried tons of things already.

    I'll put the actual error log in the next post... [ed. note: ricrempel last edited this post 13 years, 6 months ago.]
      • 25054
      • 8 Posts
      [2013-03-19 08:57:53] (ERROR @ /index.php) [phpThumbOf] Could not generate thumbnail: assets/images/stories/reinos_do_mundo.jpg - Debug: Array
      (
      [0] => phpThumb() v1.7.9-200712090829 in file "phpthumb.class.php" on line 216
      [1] => setCacheDirectory() starting with config_cache_directory = "/usr/www/users/username/cms/core/cache/phpthumb/" in file "phpthumb.class.php" on line 919
      [2] => setting config_cache_directory to realpath(/usr/www/users/username/cms/core/cache/phpthumb) = "/usr/www/users/username/cms/core/cache/phpthumb" in file "phpthumb.class.php" on line 947
      [3] => setCacheDirectory() starting with config_cache_directory = "/usr/www/users/username/cms/assets/components/phpthumbof/cache/" in file "phpthumb.class.php" on line 919
      [4] => setting config_cache_directory to realpath(/usr/www/users/username/cms/assets/components/phpthumbof/cache) = "/usr/www/users/username/cms/assets/components/phpthumbof/cache" in file "phpthumb.class.php" on line 947
      [5] => setSourceFilename(assets/images/stories/reinos_do_mundo.jpg) set $this->sourceFilename to "assets/images/stories/reinos_do_mundo.jpg" in file "phpthumb.class.php" on line 243
      [6] => skipping CleanUpCacheDirectory() set to purge (30.0 days; 100.00MB; 10,000 files) in file "phpthumb.class.php" on line 652
      [7] => file_exists() = 0 in file "phpthumb.class.php" on line 1101
      [8] => is_executable() = 0 in file "phpthumb.class.php" on line 1102
      [9] => using ImageMagick path from `which convert` (/usr/local/bin/convert) in file "phpthumb.class.php" on line 1121
      [10] => ImageMagick version checked with "convert --version" in file "phpthumb.class.php" on line 1148
      [11] => ImageMagick did not return recognized version string (Version: ImageMagick 6.8.0-7 2012-12-07 Q16 http://www.imagemagick.org
      Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC
      Features:) in file "phpthumb.class.php" on line 1154
      [12] => ImageMagick convert --version says "Unknown" in file "phpthumb.class.php" on line 1157
      [13] => $AvailableImageOutputFormats = array(text;ico;bmp;wbmp;gif;png;jpeg) in file "phpthumb.class.php" on line 884
      [14] => $this->thumbnailFormat set to $this->config_output_format "jpeg" in file "phpthumb.class.php" on line 895
      [15] => $this->thumbnailFormat set to $this->f "jpeg" in file "phpthumb.class.php" on line 902
      [16] => $this->thumbnailQuality set to "75" in file "phpthumb.class.php" on line 912
      [17] => $this->sourceFilename set to "/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg" in file "phpthumb.class.php" on line 813
      [18] => phpThumb() v1.7.9-200712090829

      "/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg" does not exist in file "phpthumb.class.php" on line 3647
      [19] => setCacheDirectory() starting with config_cache_directory = "/usr/www/users/username/cms/assets/components/phpthumbof/cache" in file "phpthumb.class.php" on line 919
      [20] => setting config_cache_directory to realpath(/usr/www/users/username/cms/assets/components/phpthumbof/cache) = "/usr/www/users/username/cms/assets/components/phpthumbof/cache" in file "phpthumb.class.php" on line 947
      [21] => SetCacheFilename() _src set from md5($this->sourceFilename) "/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg" = "cd522bf7ea70f81a50009dabd8212f87" in file "phpthumb.class.php" on line 3077
      [22] => SetCacheFilename() _par set from md5(_farC_zc1_h75_w150_dpi150_q75) in file "phpthumb.class.php" on line 3110
      [23] => starting ExtractEXIFgetImageSize() in file "phpthumb.class.php" on line 2897
      [24] => GetImageSize("/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg") failed in file "phpthumb.class.php" on line 2920
      [25] => $this->useRawIMoutput=true after checking $UnAllowedParameters in file "phpthumb.class.php" on line 1232
      [26] => phpThumb_tempnam() returning "/var/tmp/pThumbBtqmB1" in file "phpthumb.class.php" on line 3861
      [27] => ImageMagickSwitchAvailable(thumbnail) = 1 in file "phpthumb.class.php" on line 1189
      [28] => ImageMagickSwitchAvailable(density) = 1 in file "phpthumb.class.php" on line 1189
      [29] => GetImageSize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) FAILED with error "

      <b>Warning</b>: getimagesize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory in <b>/usr/www/users/username/cms/core/model/phpthumb/phpthumb.class.php</b> on line <b>1312</b>

      " in file "phpthumb.class.php" on line 1318
      [30] => GetImageSize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) failed in file "phpthumb.class.php" on line 1460
      [31] => Remaining $this->fltr after ImageMagick: (array(0) { } ) in file "phpthumb.class.php" on line 1807
      [32] => ImageMagickSwitchAvailable(quality;interlace) = 1 in file "phpthumb.class.php" on line 1186
      [33] => ImageMagick called as (convert -density 150 -thumbnail 150x75 -quality 75 -interlace line "/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg[0]" jpeg:"/var/tmp/pThumbBtqmB1" 2>&1) in file "phpthumb.class.php" on line 1826
      [34] => ImageMagick failed with message (cms: unable to open image `/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg': No such file or directory @ error/blob.c/OpenBlob/2638.
      cms: no images defined `jpeg:/var/tmp/pThumbBtqmB1' @ error/convert.c/ConvertImageCommand/3078.) in file "phpthumb.class.php" on line 1834
      [35] => ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 2927
      [36] => SetOrientationDependantWidthHeight() starting with ""x"" in file "phpthumb.class.php" on line 2876
      [37] => SetOrientationDependantWidthHeight() setting w="150", h="75" in file "phpthumb.class.php" on line 2892
      [38] => EXIF thumbnail extraction: (size=0; type=""; 0x0) in file "phpthumb.class.php" on line 2979
      [39] => starting SourceImageToGD() in file "phpthumb.class.php" on line 3229
      [40] => $this->useRawIMoutput=true after checking $UnAllowedParameters in file "phpthumb.class.php" on line 1232
      [41] => phpThumb_tempnam() returning "/var/tmp/pThumbbAJKw7" in file "phpthumb.class.php" on line 3861
      [42] => ImageMagickSwitchAvailable(thumbnail) = 1 in file "phpthumb.class.php" on line 1189
      [43] => ImageMagickSwitchAvailable(density) = 1 in file "phpthumb.class.php" on line 1189
      [44] => GetImageSize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) FAILED with error "

      <b>Warning</b>: getimagesize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory in <b>/usr/www/users/username/cms/core/model/phpthumb/phpthumb.class.php</b> on line <b>1312</b>

      " in file "phpthumb.class.php" on line 1318
      [45] => GetImageSize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) failed in file "phpthumb.class.php" on line 1460
      [46] => Remaining $this->fltr after ImageMagick: (array(0) { } ) in file "phpthumb.class.php" on line 1807
      [47] => ImageMagickSwitchAvailable(quality;interlace) = 1 in file "phpthumb.class.php" on line 1186
      [48] => ImageMagick called as (convert -density 150 -thumbnail 150x75 -quality 75 -interlace line "/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg[0]" jpeg:"/var/tmp/pThumbbAJKw7" 2>&1) in file "phpthumb.class.php" on line 1826
      [49] => ImageMagick failed with message (cms: unable to open image `/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg': No such file or directory @ error/blob.c/OpenBlob/2638.
      cms: no images defined `jpeg:/var/tmp/pThumbbAJKw7' @ error/convert.c/ConvertImageCommand/3078.) in file "phpthumb.class.php" on line 1834
      [50] => starting ImageCreateFromFilename(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) in file "phpthumb.class.php" on line 3152
      [51] => empty $filename or GetImageSize(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) failed in file "phpthumb.class.php" on line 3201
      [52] => Populating $rawimagedata in file "phpthumb.class.php" on line 3209
      [53] => cannot fopen(/usr/www/users/username/cms/assets/images/stories/reinos_do_mundo.jpg) in file "phpthumb.class.php" on line 3212
      [54] => Not using EXIF thumbnail data because $this->exif_thumbnail_data is empty in file "phpthumb.class.php" on line 3278
      [55] => $this->gdimg_source is still empty in file "phpthumb.class.php" on line 3330
      [56] => ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 3332
      [57] => phpThumb() v1.7.9-200712090829

      Unknown image type identified by "" () in SourceImageToGD()[3444] in file "phpthumb.class.php" on line 3647
      [58] => SourceImageToGD() failed in file "phpthumb.class.php" on line 323
      )