We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38357
    • 178 Posts
    Hello all,
    Running Revolution 2.2.4
    I am having problems when accessing Manager with exceeding the allocated memory allowance of 1024mb. This is relatively new and has become an intern=mittent problem over the last few weeks. I have no idea what is causing it. The server runs Cpanel.
    Every time I access Manage Users and some other functions I get the error

    Error messages are as below:

    Server Error Message:

    syntax error:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Server Errror Log:
    [Mon Mar 18 09:50:32 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/index.php, referer: http://www.qpgc.com.au/manager/?a=57
    [Mon Mar 18 09:50:32 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/index.php, referer: http://www.qpgc.com.au/manager/?a=57
    [Mon Mar 18 09:50:32 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/manager/min/index.php, referer: http://www.qpgc.com.au/manager/?a=57
    [Mon Mar 18 09:50:32 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/manager/min/index.php, referer: http://www.qpgc.com.au/manager/?a=57

    Cpanel Recources:


    Resource Usage Overview
    Your site has been limited within the past 24 hours
    CPU resources were limited for your site
    Memory resources were limited for your site
    [Details]

    Resource Usage Details
    Current Usage
    CPU Usage
    0% / 100%
    Memory Usage
    300K / 1.0G
    Entry Processes
    0 / 20

    Timeframe:  

    Usage
    From
    To
    aCPU
    mCpu
    aEP
    mEP
    lEP
    aMEM
    mMEM
    lMEM
    MemF
    MepF
    03-18 09:50
    03-18 09:51
    0
    0
    0
    0
    20
    300K
    300K
    1.0G
    0
    0
    03-18 09:49
    03-18 09:50
    40
    100
    1
    4
    20
    178.7M
    1.0G
    1.0G
    6
    0
    03-18 09:45
    03-18 09:50
    0
    0
    0
    0
    20
    24K
    24K
    1.0G
    0
    0
    03-18 09:40
    03-18 09:45
    0
    0
    0
    0
    20
    24K
    24K
    1.0G
    0
    0

    MODX Revolution Error Log:


    [2013-03-17 22:07:17] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/login/properties
    [2013-03-17 22:07:17] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/wayfinder/properties
      • 3749
      • 24,544 Posts
      That should be plenty of memory. Is it possible that you have a circular reference somewhere on your site?

      An example would be a getResources call that includes the page containing the getResources tag. The error would only show up when that getResources tag is processed.

      Another possibility is a snippet or plugin that executes on the error_page that sends users to the error_page (over and over). By default, the error_page is your home page (resource 1) unless you change the error_page System Setting.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 38357
        • 178 Posts
        Thanks for the help Bob,
        This only appears to happen when accessing the management interface as administrator. It is not an issue when the website is accessed by users. If I log on to the manager as an administrator and go to Manage Users it will overload the server. There are only 250 users on the site so I can't see how that should be a problem.
        If it were a circular reference it would be a user generated problem?

        PS - I just went to Package Manager and it crashed -- exceeded the memory limit, so it isn't just the Manage Users [ed. note: bobd72 last edited this post 13 years, 6 months ago.]
          • 3749
          • 24,544 Posts
          Since it's happening in the Manager, the most likely culprit is a rogue plugin, though I can't think of one that would act on both User Management and Package Manager.

          If it's a new install, I'd suspect a corrupted file in the core, especially if you transferred the files individually with FTP.

          If it's a plugin, the brute force method would be to disable your plugins one-by-one until the problem goes away (or disable all of them and enable them one-by-one until it comes back).
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 38357
            • 178 Posts
            Thanks Bob,
            I have upgraded to V2.2.6 and I disabled all plugins but the problem persists.

            As soon as I log on to the manager the problems begin. I get the error message immediately the dashboard opens:

            syntax error:
            Internal Server Error

            The server encountered an internal error or misconfiguration and was unable to complete your request.

            Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

            More information about this error may be available in the server error log.

            Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

            Server error shows as:
            [Thu Mar 21 12:37:37 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/index.php, referer: http://www.qpgc.com.au/manager/?a=60
            [Thu Mar 21 12:37:37 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/connectors/workspace/packages-rest.php, referer: http://www.qpgc.com.au/manager/?a=60

            The same syntax error pops up when I try to open some menu items - I can view resources OK but many menu items result in the same message. If I view my users often the usernames will not be listed at all but I get the error message - but when I refresh the usenames up they pop.

            When I log on to Manager the CPU usage goes to 100% and the memory limit of 1Gb is exceeded every time the error message appears.

            There are no problems for users on the frontend - only Manager.
            [ed. note: bobd72 last edited this post 13 years, 6 months ago.]
              • 3749
              • 24,544 Posts
              The first thing to try is deleting all files in the core/cache directory. That will make sure that disabling the plugins takes effect.

                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 38357
                • 178 Posts
                I removed all files from core/cache, deactivated all plugins, clicked System>Package Management

                The same syntax error came up - no packages were shown but when I refreshed the Package list up they all popped :-(
                  • 3749
                  • 24,544 Posts
                  It may just have been a corrupted file in the cache. I would play with it for a while with no plugins, and if the error doesn't come back, start re-enabling the plugins one at a time until it comes back.

                  If there aren't too many of them, you could list your plugins here and we might be able to guess which are the likeliest suspects.

                  BTW, I would also turn off the compress_js and compress_css System Settings.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 38357
                    • 178 Posts
                    All plugins have been disabled, cache cleared. I turned off compression for js and css but the problem persists.
                    Agggghhhh!


                      • 28042 ☆ A M B ☆
                      • 24,524 Posts
                      Hm. Action #60 is for importing flat HTML files, #57 is for working with access controls in Security.
                        Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org