If you say they were functioning last night but not today, there could be reason that the server is unable to connect. Is this a local server or remote? What host is it on? Do you know of limitations on CURL or did you see any errors in the installation? Your server may be prohibiting the connections as it may be considered malicious behaviour (but I doubt it.) Have you tried clearing the cache?I have cleared the cache multiple times. I don't know also that my local server has limitations and I didn't got any errors during my installation.
<?php phpinfo(); ?>
Is there a way to debug these connections?
Can you open up developer tools and check if there are any javascript errors or requests getting a 404 errors in the manager?No JavaScript errors or 4** or 5** requests.
Also, can you clarify what your definition of an empty dashboard is? Different elements being missing could indicate different issues, and knowing what we're talking about is a huge help. A screenshot would be perfect

Can you clear the cache by pressing the menu button? If the menu does not work in some parts, it's because its based on JavaScript here and there. And some javascript files may be missing. And: as error logging also relies on javascript (the language files), it can't tell you what is not working.See above. Also it worked, I didn't remove any files.
Can you upload a file named "info.php" or similar and put the following code in it?phpinfo():
<!--?php phpinfo(); ?-->
That should at least tell you what modules are activated and - sometimes very important - if your php runs as apache module or as fastCGI. Both works but brings different types and reasons of errors with it.
PHP Version 5.2.9-2
PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference Off Off
allow_url_fopen On On
allow_url_include Off Off
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_prepend_string no value no value
error_reporting 6143 6143
expose_php On On
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .;C:\php5\pear .;C:\php5\pear
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 30 30
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 128M 128M
open_basedir no value no value
output_buffering 1 1
output_handler no value no value
post_max_size 8M 8M
precision 14 14
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv Off Off
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from admin@localhost admin@localhost
sendmail_path no value no value
serialize_precision 100 100
short_open_tag Off Off
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
user_dir no value no value
variables_order GPCS GPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.ze1_compatibility_mode Off Off
apache2handler
Apache Version Apache/2.2.11 (Win32) PHP/5.2.9-2
Apache API Version 20051115
Hostname:Port localhost:80
Timeouts Connection: 300 - Keep-Alive: 5
Virtual Server No
Loaded Modules core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_include mod_isapi mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_php5