We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 43096
    • 3 Posts
    My original post from StackOverflow:


    I'm using MODX the first time and it all worked since yesterday. I didn't change anything and the dashboard and the package manager worked without any problems but since yesterday I couldn't see the dashboard itself, just the top navigation menu in the backend/admin manager and the left sidebar menu with the ressources, elements and file tabs. Besides this empty dashboard the package manager doesn't work too. It just shows the table headings like name, version, release etc. without a table body.

    I think that maybe the MODX Rest API is broken? My package manager source was http://rest.modx.com/extras/ and it worked a few days ago. I also tried http://rest.modxcms.com/extras/ already but it doesn't work too (returns a 404).

    I'm using MODX Revolution 2.2.6pl and I also didn't change anything on the server configuration, so allow_url_open and curl still is enabled in my PHP 5.2.9.

    I also set already the configuration value of debug in Revolution to E_ALL.
    PS: You could ask me also difficult questions or give me tips where to look under the hood to solve the problem because I'm a web developer. [ed. note: davido last edited this post 13 years, 6 months ago.]
      • 27708 MODX Staff
      • 2,502 Posts
      As I mentioned on Stack Overflow, I am not able to replicate this. I have some questions: I am assuming you are not able to see the Important News and Security Feeds in the main pane on the dashboard. I am also assuming that package management is not functioning. All of these require external connections to modx.com. If you say they were functioning last night but not today, there could be reason that the server is unable to connect. Is this a local server or remote? What host is it on? Do you know of limitations on CURL or did you see any errors in the installation? Your server may be prohibiting the connections as it may be considered malicious behaviour (but I doubt it.) Have you tried clearing the cache?
        Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
        • 43096
        • 3 Posts
        Quote from: smashingred at Mar 16, 2013, 07:48 AM
        If you say they were functioning last night but not today, there could be reason that the server is unable to connect. Is this a local server or remote? What host is it on? Do you know of limitations on CURL or did you see any errors in the installation? Your server may be prohibiting the connections as it may be considered malicious behaviour (but I doubt it.) Have you tried clearing the cache?
        I have cleared the cache multiple times. I don't know also that my local server has limitations and I didn't got any errors during my installation.
        Could you tell me there the files are which handles these foreign connections? Is there a way to debug these connections?
        Update: Maybe it's another problem? Because the config check on the dashboard is also not visible. [ed. note: davido last edited this post 13 years, 6 months ago.]
          • 18373 ☆ A M B ☆
          • 3,141 Posts
          The dashboard not being visible is not a symptom I would link to package management being down. What made you think it was that to begin with? The News and Security feeds being down could potentially cause error messages being displayed (or just being logged, depending on your server configuration), but that should not cause an empty dashboard.

          Can you open up developer tools and check if there are any javascript errors or requests getting a 404 errors in the manager?

          Also, can you clarify what your definition of an empty dashboard is? Different elements being missing could indicate different issues, and knowing what we're talking about is a huge help. A screenshot would be perfect smiley
            Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

            Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
            • 37242 ☆ A M B ☆
            • 339 Posts
            I guess if you view the source code of the manager window, you get 404 or 500 errors when you click on the lang.js file and one other around it, right?

            Can you clear the cache by pressing the menu button? If the menu does not work in some parts, it's because its based on JavaScript here and there. And some javascript files may be missing. And: as error logging also relies on javascript (the language files), it can't tell you what is not working.

            Can you upload a file named "info.php" or similar and put the following code in it?
            <?php phpinfo(); ?>

            That should at least tell you what modules are activated and - sometimes very important - if your php runs as apache module or as fastCGI. Both works but brings different types and reasons of errors with it.

            If its true what I wrote about the lang.js.php - could you check its permissions? Sometimes hosters dont allow a 777, so 775 or 755 must be set (or you get an error). Play aroud with it and please let us know what you found out smiley
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              I just noticed that the RSS feeds are indeed down. With Google's recent announcement to Reader, I'm worried they may have pulled the switch on FeedBurner (which MODX has been using for ages to serve the RSS feeds) too.

              The feeds being down will show/log errors, but shouldn't cause an empty page.
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 37242 ☆ A M B ☆
                • 339 Posts
                I had this once before with other but similar symptoms. Like the resource tree wasnt there. I bet its a permissions thing smiley
                  • 16501
                  • 28 Posts
                  Quote from: davido at Mar 16, 2013, 07:53 AM
                  Is there a way to debug these connections?

                  You could try something like HTTPWatch to see the http traffic.
                    • 37105
                    • 194 Posts
                    Missing objects on dashboard sometimes can be caused by compression of CSS and/or JS. Try to disable it in system settings.

                    @gallenkamp: missing resource tree occured in one of my latest installations and disabling these compression settings did resolve it.
                      Codeplaza Webdesign: for professional websites at low cost
                      • 43096
                      • 3 Posts
                      Quote from: markh at Mar 16, 2013, 09:06 AM
                      Can you open up developer tools and check if there are any javascript errors or requests getting a 404 errors in the manager?
                      No JavaScript errors or 4** or 5** requests.

                      Quote from: markh at Mar 16, 2013, 09:06 AM
                      Also, can you clarify what your definition of an empty dashboard is? Different elements being missing could indicate different issues, and knowing what we're talking about is a huge help. A screenshot would be perfect smiley



                      Quote from: gallenkamp at Mar 16, 2013, 09:09 AM
                      Can you clear the cache by pressing the menu button? If the menu does not work in some parts, it's because its based on JavaScript here and there. And some javascript files may be missing. And: as error logging also relies on javascript (the language files), it can't tell you what is not working.
                      See above. Also it worked, I didn't remove any files.

                      Quote from: gallenkamp at Mar 16, 2013, 09:09 AM
                      Can you upload a file named "info.php" or similar and put the following code in it?
                      <!--?php phpinfo(); ?-->

                      That should at least tell you what modules are activated and - sometimes very important - if your php runs as apache module or as fastCGI. Both works but brings different types and reasons of errors with it.
                      phpinfo():
                      PHP Version 5.2.9-2

                      PHP Core
                      Directive Local Value Master Value
                      allow_call_time_pass_reference Off Off
                      allow_url_fopen On On
                      allow_url_include Off Off
                      always_populate_raw_post_data Off Off
                      arg_separator.input & &
                      arg_separator.output & &
                      asp_tags Off Off
                      auto_append_file no value no value
                      auto_globals_jit On On
                      auto_prepend_file no value no value
                      browscap no value no value
                      default_charset no value no value
                      default_mimetype text/html text/html
                      define_syslog_variables Off Off
                      disable_classes no value no value
                      disable_functions no value no value
                      display_errors On On
                      display_startup_errors Off Off
                      doc_root no value no value
                      docref_ext no value no value
                      docref_root no value no value
                      enable_dl On On
                      error_append_string no value no value
                      error_prepend_string no value no value
                      error_reporting 6143 6143
                      expose_php On On
                      file_uploads On On
                      highlight.bg #FFFFFF #FFFFFF
                      highlight.comment #FF8000 #FF8000
                      highlight.default #0000BB #0000BB
                      highlight.html #000000 #000000
                      highlight.keyword #007700 #007700
                      highlight.string #DD0000 #DD0000
                      html_errors On On
                      ignore_repeated_errors Off Off
                      ignore_repeated_source Off Off
                      ignore_user_abort Off Off
                      implicit_flush Off Off
                      include_path .;C:\php5\pear .;C:\php5\pear
                      log_errors On On
                      log_errors_max_len 1024 1024
                      magic_quotes_gpc Off Off
                      magic_quotes_runtime Off Off
                      magic_quotes_sybase Off Off
                      mail.force_extra_parameters no value no value
                      max_execution_time 30 30
                      max_input_nesting_level 64 64
                      max_input_time 60 60
                      memory_limit 128M 128M
                      open_basedir no value no value
                      output_buffering 1 1
                      output_handler no value no value
                      post_max_size 8M 8M
                      precision 14 14
                      realpath_cache_size 16K 16K
                      realpath_cache_ttl 120 120
                      register_argc_argv Off Off
                      register_globals Off Off
                      register_long_arrays Off Off
                      report_memleaks On On
                      report_zend_debug On On
                      safe_mode Off Off
                      safe_mode_exec_dir no value no value
                      safe_mode_gid Off Off
                      safe_mode_include_dir no value no value
                      sendmail_from admin@localhost admin@localhost
                      sendmail_path no value no value
                      serialize_precision 100 100
                      short_open_tag Off Off
                      SMTP localhost localhost
                      smtp_port 25 25
                      sql.safe_mode Off Off
                      track_errors Off Off
                      unserialize_callback_func no value no value
                      user_dir no value no value
                      variables_order GPCS GPCS
                      xmlrpc_error_number 0 0
                      xmlrpc_errors Off Off
                      y2k_compliance On On
                      zend.ze1_compatibility_mode Off Off

                      apache2handler
                      Apache Version Apache/2.2.11 (Win32) PHP/5.2.9-2
                      Apache API Version 20051115
                      Hostname:Port localhost:80
                      Timeouts Connection: 300 - Keep-Alive: 5
                      Virtual Server No
                      Loaded Modules core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_include mod_isapi mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_php5