We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8168
    • 1,118 Posts
    Hi guys,

    Just installed 2.2.6pl and Articles 1.6.4 on PHP 5.3.22 with mySQL 5.1.68 and when I turned on Search Friendly URLs and switched the ht.access file to .htaccess - When I view pages using their friendly url I get:

    PHP error debug
      Error: 	Function eregi() is deprecated	 
      Error type/ Nr.: 	- 8192	 
      File: 	manager/includes/document.parser.class.inc.php(746) : eval()'d code	 
      Line: 	32
    


    Any ideas?

    This question has been answered by sottwell. See the first response.

      • 8168
      • 1,118 Posts
      Ahh... think I have solved this - nothing to do with the new install... this is in a subfolder - and I think the error is on the root version of MODx on this server...
      • discuss.answer
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        Yes, many of the older snippets have similar problems. That particular error structure means the error is in an Evo snippet or plugin on line 32 of that snippet or plugin, not in the MODx core itself.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 8168
          • 1,118 Posts
          Thanks Susan. Yeh I have an old version running in the root of this server and since the PHP 5.3 upgrade I guess it has been problematic...