We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 11681
    • 98 Posts
    I have encountered a puzzling error after moving a Revo 2.2.5-pl site from Hosting Service A to Hosting Service B. (Not naming names.) I've used Service A for both Evo and Revo hosting for years without problems. Service B is an advertiser on the MODX Web site.

    The public-facing Web site looks & works fine on Service B. However, after login to the Revo Manager, sooner or later this message appears in a pop-up:
    syntax error:
    Yes, just those two words appear in lower case, followed by a colon. There is no further text describing the error.

    I cannot make the message appear reliably, whenever I want to, by clicking through Manager functions in a particular order. Appearance of the message is seemingly random, though frequent.

    Despite this message, the particular Manager features I use seem to work with no problems.

    Grep-search of the Revo installation for "syntax error" suggests that the built-in Smarty templating system is the source of the message.

    Service B customer service assures me that their other Revo users aren't seeing this problem. Nor am I encountering it on my local XAMPP development machine.

    Ideas as to cause and how to debug? What further information would be helpful for me to provide?

    Thanks!
      I looked just like that in 1964.
      • 11681
      • 98 Posts
      No one answered. Too bizarre, I suppose.

      Having fought with the problem for more than a month, I believe that the cause is as described here:

      https://forums.modx.com/thread/83823/help-error-after-upgrading-modx-rev-from-2-2-6-pl-to-2-2-7-pl-syntax-error-internal-server-error?page=2#dis-post-463394
        I looked just like that in 1964.