We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 42286
    • 3 Posts
    Okay, this one has been bugging me for a while, and I can't seem to figure out exactly what's causing it.

    Here's a page that exists.

    Take a look at the design. Keep that in mind as you visit a page that doesn't exist.

    Note the four characters at the top of the page, inside the page-wide blue bar. For me, right now, they're "3079". They change when I modify the site settings to use a different page as the error page, or when I change what template the error page is using. Currently, however, two pages linked above are using the exact same template.

    If you view the source of the error page, you'll see that the characters are being injected right before the DOCTYPE, like MODX is outputting those first, and then the rest of the page.

    Does anyone have any idea what the heck is going on here?
      • 3749
      • 24,544 Posts
      I see a regular 404 page on the second link -- no extra characters. View source shows DOCTYPE at the very top. Maybe you fixed it?
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        Have you put the template through the W3C validator? You can't have a class in the doctype declaration.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 42286
          • 3 Posts
          Well, took me long enough to get back to this. smiley

          @sottwell: You're right. That snuck in there on a search-and-replace I'm guessing. Fixed now.

          @BobRay: Nope. But we did figure out that it only happens internally, after the site gets passed through our proxy server. So, like as not, it's a proxy issue and not a MODX issue.