Hi,
I've followed most of the threads in this and have managed to get furls partially working.
However when I try to follow a link I get this error message
Fatal error: Call to undefined method modX::getFullTableName() in /home/hotbutto/public_html/core/cache/includes/elements/modplugin/2.include.cache.php on line 31
Any tips?
Thanks
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} ^www.makethemclick.net [NC]
RewriteRule ^(.*)$ http://makethemclick.net.au/$1 [L,R=301]
# Friendly URLs
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
# Additional Settings Follow
ExpiresActive On
ExpiresByType image/gif A2592000
ExpiresByType image/jpeg A2592000
ExpiresByType image/png A2592000
BrowserMatch "MSIE" brokenvary=1
BrowserMatch "Mozilla/4.[0-9]{2}" brokenvary=1
BrowserMatch "Opera" !brokenvary
SetEnvIf brokenvary 1 force-no-vary
[ed. note: markg last edited this post 13 years, 7 months ago.]
Content Creator and Copywriter
Content Creator and Copywriter
-
☆ A M B ☆
- 24,524 Posts
This is two totally different problems.
The error is caused by the plugin (plugin #2) having bad code.
modX->getFullTableName() -
modX->getTableName($className, $includeDb=false)
or modX->escape($customTableName)
http://rtfm.modx.com/display/revolution20/Summary+of+Legacy+Code+Removed+in+2.1
For the URL issue, try setting the use_alias_path system setting to Yes.
Content Creator and Copywriter
-
☆ A M B ☆
- 24,524 Posts
Do you have some kind of URL-manipulating plugin active?
Susan,
I think the htaccess is actually ok. Turning on the use_alias_path system setting to Yes got rid of the error but as I said above, now the middle part of the url is getting repeated somehow in the links on the page.
I'm thinking there's another error somewhere else that may not be related to furls.
Content Creator and Copywriter
-
☆ A M B ☆
- 24,524 Posts
You still have the bad code in that plugin #2. Get that fixed before you try to deal with the URL issue.
Hmmm,
turning the use_alias_path system setting off makes the correct urls show up on the links within a page, however it strips the containers from the actual page. I hope that makes sense
eg With the setting off, the links within a page look like this
http://makethemclick.net/social-media-marketing/linkedin-deletes-your-web-and-blog-links And that's how they should look.
But the actual page has this url
http://makethemclick.net/linkedin-deletes-your-web-and-blog-links ie not correct.
Turning the setting back on gives me links on the page like this
http://makethemclick.net/library/library/social-media-marketing/linkedin-deletes-your-web-and-blog-links not correct.
And on some pages also gives me the fatal error above.
aye, aye aye.
Content Creator and Copywriter
Susan,
I noticed that, thing is there is no plugin being used.
????????
Content Creator and Copywriter
-
☆ A M B ☆
- 24,524 Posts
You don't have a plugin #2 in the Elements tab?