I'm getting 502 Bad Gateway - On all my Cloud sites hosted on Amsterdam server.
Is it just me?
-
☆ A M B ☆
- 70 Posts
I'm getting the same error message too on paas2.ams. paas1.ams is fine. I received a PingdomAlert @ 10.26AM (CET) 17/02/2013.
[ed. note: jonleverrier last edited this post 13 years, 7 months ago.]
-
☆ A M B ☆
- 24,524 Posts
-
☆ A M B ☆
- 3,141 Posts
We've just located the issue and are patching as fast as we can.
-
☆ A M B ☆
- 3,141 Posts
Sites should be back up now.
-
☆ A M B ☆
- 3,141 Posts
I'm truly sorry for what happened this morning. For transparency sakes (and anyone who submitted a support ticket through the Cloud Dashboard already knows this), the cause ended up being a core configuration issue. This has been fixed on the affected platform and we'll be reviewing with our provider on what other steps we can take to prevent outages like this.
Hi Mark,
Thanks for sorting it out and the explanation.
Does make me feel slightly nervous about hosting on nginx machines, these "502 Bad Gateway" errors seem to occur quite regularly.
-
☆ A M B ☆
- 3,141 Posts
In most cases, the 502 Bad Gateway comes from something that is not nginx, actually. Everything from internal server errors, PHP throwing up, a server running out of disk space, or a related MongoDB instance going down could manifest itself as a bad gateway error.
In this specific case it was indeed a nginx configuration issue related to the growth of cloud usage, one that could have happened on apache as well. Generally speaking, nginx easily outperforms apache in terms of performance handling concurrent requests, and it is insanely flexible with easy configuration.
-
☆ A M B ☆
- 24,524 Posts
All was well when I was working on a dev Cloud this morning. Now when editing or when saving resources I get either a blank page or a bad gateway error.