I just did a fresh install on my local machince:
windows 7 64bits
Downloaded the latest modx revo
running wamp
install went without a hitch, but when I try to log in with my admin username and password, I get no error, and the page seems to just refresh back to the login page.
I have looked all over the web, been trying to figure this out for the last couple of hours but can't login. I am stuck. Can anyone help me out?
Thanks!
www.JBMWebDesign.com
www.JBMAutomation.com
I found this, but it says it applies to old revo installs. This is not an old beta version, it is a fresh install
The login page keeps redirecting me back to the login screen with no error
This can happen with older Revolution beta installs. To fix it, delete the following 3 system settings from the DB table `[prefix]_system_settings` (where prefix is your table prefix):
session_name
session_cookie_path
session_cookie_domain
Then delete the core/cache/config.cache.php file.
Unless, of course, you've changed these explicitly for some purpose of your own.
www.JBMWebDesign.com
www.JBMAutomation.com
Tried this, no go. Deleted the database and the modx install, started over. Same issue. I need help!
Server Configuration
Apache Version : 2.2.22
PHP Version : 5.4.3
MySQL Version : 5.5.24
Another thing I have noticed is that when I click the forgot password link and enter the email address I used to set it up, it say no user with that email....
Any ideas?
Quote from: jasonmonette at Feb 15, 2013, 10:04 PMI found this, but it says it applies to old revo installs. This is not an old beta version, it is a fresh install
The login page keeps redirecting me back to the login screen with no error
This can happen with older Revolution beta installs. To fix it, delete the following 3 system settings from the DB table `[prefix]_system_settings` (where prefix is your table prefix):
session_name
session_cookie_path
session_cookie_domain
Then delete the core/cache/config.cache.php file.
Unless, of course, you've changed these explicitly for some purpose of your own.
www.JBMWebDesign.com
www.JBMAutomation.com
-
☆ A M B ☆
- 3,141 Posts
Few things you can do:
- clear cache and cookies for your domain - it could be a cookie conflict of sorts.
- make sure the session_cookie_secure setting is disabled, unless your manager is served exclusively over SSL.
- check the MODX error log in core/cache/logs/error.log to check for any errors.
-- It is a local install, I did clear my browsers cache
--This is what the session_cookie_secure looks like:
Value =
xType = combo-boolean
namespace = core
area = session
editedon = 0000-00-00 00:00:00
how do i make sure this is disabled?
--There is no file named error.log in the log folder
Thanks for your help, I hope we can get this working!
Quote from: markh at Feb 16, 2013, 02:15 PMFew things you can do:
- clear cache and cookies for your domain - it could be a cookie conflict of sorts.
- make sure the session_cookie_secure setting is disabled, unless your manager is served exclusively over SSL.
- check the MODX error log in core/cache/logs/error.log to check for any errors.
www.JBMWebDesign.com
www.JBMAutomation.com
the database says I have logged in 3 times, yet I have never gotten past the login page. it just seems locked on the log in page
www.JBMWebDesign.com
www.JBMAutomation.com
Sounds like a permission issue, though it never happened to me with a default user.
Maybe the admin user group doesn't have the proper acl attached to it
Try emptying and/or repairing the modx_session table in PhpMyAdmin.
While you're there, check the compress_js and compress_css setting in the modx_system_settings table. Try setting both to 0.
Then, delete all files in the core/cache directory and clear your browser cache *and cookies* before trying to log in again.