On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • This is what i get when opening the setup folder:

    $argv) { $p = explode('=',ltrim($argv,'--')); if (isset($p[1])) { $_REQUEST[$p[0]] = $p[1]; } } if (!empty($_REQUEST['core_path']) && is_dir($_REQUEST['core_path'])) { define('MODX_CORE_PATH',$_REQUEST['core_path']); } if (!empty($_REQUEST['config_key'])) { define('MODX_CONFIG_KEY',$_REQUEST['config_key']); } } /* check for compatible PHP version */ define('MODX_SETUP_PHP_VERSION', phpversion()); $php_ver_comp = version_compare(MODX_SETUP_PHP_VERSION, '5.1.1'); if ($php_ver_comp < 0) { die('
    FATAL ERROR: MODX Setup cannot continue.

    Wrong PHP version! You\'re using PHP version '.MODX_SETUP_PHP_VERSION.', and MODX requires version 5.1.1 or higher.
    '); } /* make sure json extension is available */ if (!function_exists('json_encode')) { die('
    FATAL ERROR: MODX Setup cannot continue.

    MODX requires the PHP JSON extension! You\'re PHP configuration at version '.MODX_SETUP_PHP_VERSION.' does not appear to have this extension enabled. This should be a standard extension on PHP 5.2+; it is available as a PECL extension in 5.1.
    '); } /* make sure date.timezone is set for PHP 5.3.0+ users */ if (version_compare(MODX_SETUP_PHP_VERSION,'5.3.0') >= 0) { $phptz = @ini_get('date.timezone'); if (empty($phptz)) { die('
    FATAL ERROR: MODX Setup cannot continue.

    To use PHP 5.3.0+, you must set the date.timezone setting in your php.ini. Please do set it to a proper timezone before proceeding. A list can be found here.
    '); } } if (!$isCommandLine) { $https = isset($_SERVER['HTTPS']) ? $_SERVER['HTTPS'] : false; $installBaseUrl= (!$https || strtolower($https) != 'on') ? 'http://' : 'https://'; $installBaseUrl .= $_SERVER['HTTP_HOST']; if ($_SERVER['SERVER_PORT'] != 80) $installBaseUrl= str_replace(':' . $_SERVER['SERVER_PORT'], '', $installBaseUrl); $installBaseUrl .= ($_SERVER['SERVER_PORT'] == 80 || ($https !== false || strtolower($https) == 'on')) ? '' : ':' . $_SERVER['SERVER_PORT']; $installBaseUrl .= $_SERVER['PHP_SELF']; define('MODX_SETUP_URL', $installBaseUrl); } else { define('MODX_SETUP_URL','/'); } /* session loop-back tester */ if (!$isCommandLine && (!isset($_GET['s']) || $_GET['s'] != 'set') && !isset($_SESSION['session_test'])) { $_SESSION['session_test']= 1; echo "




    And this is what it says in my wamp config file:
    wampserverVersion = 2.2
    phpVersion = "5.4.3"
    phpCliVersion = 5.4.3
    apacheVersion = "2.4.2"
    mysqlVersion = "5.5.24"

    So what should i do?