On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello,

    I trying to upgrade from 1.2 to 1.7 or 1.8 and when I get the upgrade it will not allow me to log into the CMS... any ideas to why this is occurring would be great.

    Thanks
    • Try clearing your browser cache and the cookies for the domain. This usually happens to me if I'm still logged in to the manager when I do the upgrade.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • Susan,

        I tried removing clearing history, cache and cookies, it did not help. I tried flushing the DNS, it did not work.
        What I have done is over wrote the old files, yes I backed everything up, then did the install. I have done this several times. Each time I have tried to up grade I would re-upload the old files and each time I re-uploaded the old files it worked. What it appears me is that the login box is not connected to the program. What it does it when I put my credentials in it acts like it is going to load and then just clears the password box. I am not sure where to begin in tracking this down.

        Thanks you for any help or direction

        Jeff
        • Hello Susan,

          Here is the error log....

          [09-Feb-2013 22:09:25] PHP Warning: include_once(config.inc.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home/user/public_html/manager/processors/login.processor.php on line 14
          [09-Feb-2013 22:09:25] PHP Warning: include_once() [<a href='function.include'>function.include</a>]: Failed opening 'config.inc.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php:../includes/') in /home/user/public_html/manager/processors/login.processor.php on line 14
          [09-Feb-2013 22:09:25] PHP Fatal error: Call to undefined function startcmssession() in /homeuser/public_html/manager/processors/login.processor.php on line 17


          Which seem to follow maybe my conclusion that there is a path issue?

          Thanks
          • Try to update it so that you don't overwrite any old files but instead add/overwrite only your site specific files from your backup and see what happens.