Hello,
I tried to install 2.2.6 advanced and traditional, but cannot access the manager because database tables are missing after installation.
I first installed via advanced package and placed core outside public html and renamed connectors and manager. Everything went ok with the install, no errors or warnings.
After installation, the setup redirects automatically to manager directory, but I got 503 Error. Looked at core/cache/logs/error.log and it said the following:
[2013-02-03 01:45:23] (ERROR @ /setup/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_context_setting' doesn't exist
)
[2013-02-03 01:45:23] (ERROR @ /setup/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_access_policies' doesn't exist
)
[2013-02-03 01:45:23] (ERROR @ /setup/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_context_setting' doesn't exist
)
[2013-02-03 01:45:23] (ERROR @ /setup/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_access_policies' doesn't exist
)
[2013-02-03 01:46:10] (ERROR @ /manager/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_session' doesn't exist
)
[2013-02-03 01:46:10] (ERROR @ /manager/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_access_policies' doesn't exist
)
[2013-02-03 01:46:10] (ERROR @ /manager/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_session' doesn't exist
)
[2013-02-03 01:46:10] (ERROR @ /manager/index.php) Error 42S02 executing statement:
INSERT INTO `modx_session` (`id`, `access`, `data`) VALUES ('ocv954723o2iorct7sr904maq2', 1359848770, '')
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'modx.modx_session' doesn't exist
)
Then I tried the traditional archive, but same thing happens. context_setting, access_policies and session tables are missing after installation.
The show tables command in mysql shows that the following tables are created during installation:
mysql> show tables;
+------------------------------------+
| Tables_in_modx |
+------------------------------------+
| modx_access_actiondom |
| modx_access_actions |
| modx_access_category |
| modx_access_context |
| modx_access_elements |
| modx_access_media_source |
| modx_access_menus |
| modx_access_permissions |
| modx_access_policy_template_groups |
| modx_access_policy_templates |
| modx_access_resource_groups |
| modx_access_resources |
| modx_access_templatevars |
| modx_actiondom |
| modx_actions |
| modx_actions_fields |
| modx_active_users |
| modx_categories |
| modx_categories_closure |
| modx_class_map |
| modx_context |
| modx_dashboard |
| modx_dashboard_widget |
| modx_dashboard_widget_placement |
| modx_document_groups |
| modx_element_property_sets |
| modx_fc_profiles |
| modx_fc_profiles_usergroups |
| modx_fc_sets |
| modx_lexicon_entries |
| modx_manager_log |
| modx_media_sources |
| modx_media_sources_contexts |
| modx_media_sources_elements |
| modx_member_groups |
| modx_namespaces |
| modx_property_set |
| modx_register_topics |
| modx_site_content |
| modx_site_htmlsnippets |
| modx_site_plugins |
| modx_site_snippets |
| modx_site_templates |
| modx_site_tmplvar_access |
| modx_site_tmplvar_contentvalues |
| modx_site_tmplvar_templates |
| modx_site_tmplvars |
| modx_system_eventnames |
| modx_system_settings |
| modx_user_attributes |
| modx_user_messages |
| modx_user_settings |
| modx_users |
+------------------------------------+
53 rows in set (0.00 sec)
mysql>
Why are the tables missing and what should I do to get it resolved?
Thanks!
Server information:
PHP Version 5.4.11
MySQL 5.5.29
Every component installed into PHP as specified in the installation requirements.