Hello,
Quite an urgent problem over here.
I created an upgraded version (1.0.8) of the website in a subfolder called /Upgrade. The installation does not have a separate db but uses the same db as the current online site. Within the /Upgrade folder the website works fine. But when I move the installation to the root of the website, I get the following error:
Warning: require_once(/customers/e/0/e/entervzw.be/httpd.www/Upgrade/manager/includes/protect.inc.php): failed to open stream: No such file or directory in /customers/e/0/e/entervzw.be/httpd.www/Upgrade/index.php on line 52 Fatal error: require_once(): Failed opening required '/customers/e/0/e/entervzw.be/httpd.www/Upgrade/manager/includes/protect.inc.php' (include_path='.:/usr/share/php') in /customers/e/0/e/entervzw.be/httpd.www/Upgrade/index.php on line 52
A similar error appear when I try to open the manager.
What am I doing wrong? Am I missing something?
Any suggestions are very welcome.
Many tnx
Gino
It seems that the 'dirname(__FILE__)' is not always returning the current path but the previous path !?
require_once(dirname(__FILE__).'/manager/includes/protect.inc.php');
Anyone?
Many tnx
Gino
-
☆ A M B ☆
- 756 Posts
clear you cache folder; check your config for the base_path & manager_path info; re-run the setup to help fix any db path(s) settings;
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
Be sure to run install before doing the steps above.
Yes, we cleared cache and run the install.
Since the website was completely functional in the /Upgrade directory before we moved the files to the root, I'm currently thinking that there is a delay or something when you move >1GB of files. I'm talking to my 'cheap' hosting company about this now.
Meanwhile, I enabled the previous version of the website again which initially had the same problem !. But when I woke up this morning tit was working again. That's why I'm thinking about a delay.
Many tnx
Gino