On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.

Answered SPForm on Cloud

Subscribe: RSS
  • I can't imagine how that would happen unless you installed SPForm in addition to downloading it. Installing any extra will reset its default properties. That's the point of using a Property Set instead of the default properties. A property set of your own should survive anything.
      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
    • SPForm was already installed and being used on a standalone MODX (non-cloud) install. It was Vaporized.

      I've had problems with Property Sets and I think it's a Vapor issue related to my particular server. Nothing else adds up.

      Something somewhere is fundamentally out of whack. I'm ready to give up the Cloud and go back to my time-wasting stressful days of multiple MODX installs on various servers. Heck, I can't even get FormIt to work. GetResources Property sets aren't working either. Neither is the clear cache, even after I manually delete the core/cache directory.

      That's why I say something is out of whack and SPForm seems to be the most obvious symptom.
      • Hasn't there been something said about Vapor and property sets before?
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
        • I had issues with Property Sets before but that was on a different server and site.

          To recap the weirdness: SPForm was installed. No Property Sets were used other than the default at install. 4 months later I was browsing Packages and noticed that SPForm displayed the "download" button as if it weren't already downloaded.

          I think I know what it might be. Let me get back on this much later today. I've got meetings this morning.
          • UltraSEF, If you are encountering specific issues related to a site that isn't working in Cloud it might be beneficial to submit a support request where you feel that it's the environment or Vapor. Be sure to include the Cloud adress in the form of c0xxx.paasxx.xxx.modxcloud.com and your account name. You can submit a ticket directly from your Dashboard via the help tab.

            Cheers,

            Jay
              Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. BlogTwitterLinkedInGitHub
            • discuss.answer
              Did it Jay. YJ gave me 2 options. #1 seems to be working. I'll wait until tomorrow to mark this solved and what solved it.

              UPDATE: Support suggested I reinstall MODX into the Cloud. I'd NEVER do that in traditional hosting environment.

              Reinstalling MODX into the Cloud did the trick. It acted as a reset button. The site was MODX 2.2.4 before it was Vaporized into the Cloud. It subsequently was updated to to 2.2.5 and 2.2.6.

              With the Reinstall, everything works as it should. [ed. note: ultrasef last edited this post 6 years, 7 months ago.]