1. I've inherited a modx install from another developer and I've never worked on this platform before.
2. I copied the entire site to my local machine, set up the db, and ensured that the site does in fact connect to the data and that the paths are correct.
3. I have cleared the cache folder completely, as well as the sessions in the db.
When I launch the site locally, I get "Fatal error: Class 'ModSync_Plugin_ModSync' not found in /home/couchich/core/cache/includes/elements/modplugin/1.include.cache.php on line 7"
4. I have gone into the plugins/snippets tables and "unlocked" them thinking that this was the issue but no luck. I also disabled the plugin inside the plugins table, but then I start getting another error when it loads a snippet.
5. A new set of cache files as well as a new user session is created when I launch the site locally, so I know the paths and the db connection is working, but the site literally will not load up, and instead just white-screens with this php error.
6. I copied the site to a local version of XAMPP and also a live dev environment on CentOS, and the exact same error pops up.
7. I tried setting nobody:nobody as well as 777 on every file/folder in the entire install just to rule out any kind of permissions issue.
Can anyone help me thing of anything else I can check/do to get this working?
-
☆ A M B ☆
- 1,780 Posts
Have you run setup?
Get a copy of the same version of MODX that is installed from
http://modx.com and upload the zip file to your server. Extract the file on the server (do not extract locally and upload through ftp), copy all the extracted files and merge them with the existing files at your install location. Now you have a setup folder. Go to yoursite.com/setup, select the upgrade option. Run it.
oops, I see this is on localhost. Extract it locally then, of course. For production servers however, use the above method.
1. Installation Summary - Core installation was successful. Click next to complete the installation process.
2. /manager - this page loads. I tried using a bad un/pw combo to make sure it was actually processing the login script - it does.
3. /manager - i successfully logged in, then was returned to the home page and got the same error:
Fatal error: Class 'ModSync_Plugin_ModSync' not found in /Applications/XAMPP/xamppfiles/htdocs/xampp/clients/local.couchichinginstitute.ca/core/cache/includes/elements/modplugin/1.include.cache.php on line 7
-
☆ A M B ☆
- 1,780 Posts
What is your plugin ID 1?