There seems to be no shortage of posts about this problem but so far none of the solutions have worked for me.
I have a duplicate install of a live site on a subdomain (same server as the live site, separate db) which was working fine, then for some reason the site pages are now blank though the back-end (Manager) is fine. I can login, make edits etc. but when previewing from within MODX or manually typing the url, the pages are blank. Aside from being installed on a subdomain, everything is identical. I've deleted/reinstalled both the Revo install and the db and deleted the contents of the cache directory to no avail. It's probably something simple but I can't see it.
Revo 2.2.6
Linux/Apache
Todd
Did this happen when you turned on Friendly URLs or was the site ever on a temporary (~sitename) domain?
What you're seeing most often has to do with the .htaccess file, since that's often bypassed in the Manager. Sometimes hosts mess with the .htaccess file and some hosts actually mess with the way the domain name is processed without telling you.
-
☆ A M B ☆
- 24,524 Posts
This usually indicates a fatal PHP error somewhere. Check the Manager's error log, and if possible take a look at your server logs as well.
You can also try deleting all the folders under the core/cache folder, as well as making sure to clear your browser's cache and the cookies for the domain.
Susan's point is a good one. The PHP error is usually in a Plugin -- often a PHP warning caused by a PHP upgrade. You can disable plugins one by one to see which one it is.
If you can fix it by changing the PHP error reporting level to not give E_NOTICE errors, that's definitely the problem.
Then it's very likely a problem with a plugin as Susan suggested unless the .htaccess file has changed.
Sometimes there's a clue to which plugin it is in the MODX error log.
-
☆ A M B ☆
- 24,524 Posts
Nothing may have been changed by you, but hosting providers very often upgrade their PHP, MySQL, security application settings, or other server-side configurations without any warning.
In a php.ini file in the MODX root (create one if it doesn't exist) add this line:
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED