We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40088
    • 708 Posts
    There seems to be no shortage of posts about this problem but so far none of the solutions have worked for me.

    I have a duplicate install of a live site on a subdomain (same server as the live site, separate db) which was working fine, then for some reason the site pages are now blank though the back-end (Manager) is fine. I can login, make edits etc. but when previewing from within MODX or manually typing the url, the pages are blank. Aside from being installed on a subdomain, everything is identical. I've deleted/reinstalled both the Revo install and the db and deleted the contents of the cache directory to no avail. It's probably something simple but I can't see it.

    Revo 2.2.6
    Linux/Apache
      Todd
      • 3749
      • 24,544 Posts
      Did this happen when you turned on Friendly URLs or was the site ever on a temporary (~sitename) domain?

      What you're seeing most often has to do with the .htaccess file, since that's often bypassed in the Manager. Sometimes hosts mess with the .htaccess file and some hosts actually mess with the way the domain name is processed without telling you.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        This usually indicates a fatal PHP error somewhere. Check the Manager's error log, and if possible take a look at your server logs as well.

        You can also try deleting all the folders under the core/cache folder, as well as making sure to clear your browser's cache and the cookies for the domain.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 3749
          • 24,544 Posts
          Susan's point is a good one. The PHP error is usually in a Plugin -- often a PHP warning caused by a PHP upgrade. You can disable plugins one by one to see which one it is.

          If you can fix it by changing the PHP error reporting level to not give E_NOTICE errors, that's definitely the problem.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 40088
            • 708 Posts
            Quote from: BobRay at Jan 06, 2013, 10:41 PM
            Did this happen when you turned on Friendly URLs or was the site ever on a temporary (~sitename) domain?

            FURLs was always on. Apart from upgrading to 2.2.6 nothing else was changed by me prior to the problem, it had been working fine on a subdomain for months. It was never on a temp. domain.
              Todd
              • 3749
              • 24,544 Posts
              Then it's very likely a problem with a plugin as Susan suggested unless the .htaccess file has changed.

              Sometimes there's a clue to which plugin it is in the MODX error log.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 28042 ☆ A M B ☆
                • 24,524 Posts
                Nothing may have been changed by you, but hosting providers very often upgrade their PHP, MySQL, security application settings, or other server-side configurations without any warning.
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 40088
                  • 708 Posts
                  Quote from: BobRay at Jan 06, 2013, 11:02 PM
                  Then it's very likely a problem with a plugin as Susan suggested unless the .htaccess file has changed.

                  The error log is blank. All plugins were disabled but nothing changed. And I don't know how to change PHP error reporting to not give E_NOTICE errors.
                    Todd
                    • 40088
                    • 708 Posts
                    Quote from: sottwell at Jan 06, 2013, 11:08 PM
                    Nothing may have been changed by you, but hosting providers very often upgrade their PHP, MySQL, security application settings, or other server-side configurations without any warning.

                    If that were the problem then wouldn't it also affect the live site and not just the subdomain install? They are both part of the same hosting account/domain/server.
                      Todd
                      • 3749
                      • 24,544 Posts
                      In a php.ini file in the MODX root (create one if it doesn't exist) add this line:

                      error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting