We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34178
    • 212 Posts
    After forcing the manager-pages to ssl (https) by htaccess (all files in the manager-folder) the resource-tree in the backend is not visible anymore. Instead of the resources we get at that place the error 'Access denied'

    It looks like this error-message is displayed by the file connectors/system/index.php

    Does anybody know which files we might also force to ssl to avoid this error? Or does this error have another reason?

    PS: This error appears in Chrome and Opera but not in Firefox ...

    This question has been answered by multiple community members. See the first response.

    [ed. note: lettis last edited this post 13 years, 9 months ago.]
    • discuss.answer
      • 22303 MODX Staff
      • 10,725 Posts
      You'll need to make sure the connectors are also being served by your https domain. Did you update the Context Settings for mgr so the urls are constructed with https?
        • 34178
        • 212 Posts
        Hi opengeek,
        I think I need an explanation how to update the Context Settings.

        I went to System -> Contexts -> right-click on 'mgr' -> Update Context -> ? At this point I didn´t find anything to update Context Settings.
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          It may have something to do with the link_tag_scheme setting in the Site area of System Settings. I can't make heads nor tails of this list of options, though...

          -1 : (default value) URL is relative to site_url 0 : see http 1 : see https full : URL is absolute, prepended with site_url from config abs : URL is absolute, prepended with base_url from config http : URL is absolute, forced to http scheme https : URL is absolute, forced to https scheme
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 34178
            • 212 Posts
            I now have set the link_tag_scheme for mgr to 'https' and also added in the .htaccess these lines:

            RewriteCond %{HTTPS} =off
            RewriteCond %{REQUEST_URI} \/connectors\/.*
            RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]


            I also flushed Permissions and Sessions and cleared the cache of modx and of Chrome but in Chrome I still get the message "Access denied." instead of the tree on the left site but only for the site https://www.herzstiftung.de/manager/ while other managersites show the tree normally.

            Same problem for the error-log-site: https://www.herzstiftung.de/manager/?a=61 which also shows the Access denied message on the left site instead of the tree and also shows a very old error message instead of the regular error-log.

            Do you have any idea what could be the reason for this mysterious behavior?

            Letti

            PS: Maybe this is a problem of modx with Chrome because in Opera for example everything is shown normally without the Access denied message ...
            • discuss.answer
              • 34178
              • 212 Posts
              Hi Susan and Opengeek,

              we now could solve the problem. The reason was our cache. Although we used clear cache by Ctrl+Shift+k (I am not sure if this is the same as clearing the cache by Menu->Site->Clear Cache) the file has not been deleted. We now did this manually by ftp and now everything is fine.

              Because of this trouble we would like to ask if it is normal that 'Clear Cache' in Modx doesn´t clear the complete cache or is this a misconfiguration of our system?

              Thanks a lot again for your help.
              Letti
              • discuss.answer
                • 3749
                • 24,544 Posts
                The site's Clear Cache actually refreshes the cache now, so you may not notice files being removed. I think the keyboard shortcut does the same thing. I think there are some files that are not altered when you do this. Your problem could also be caused by a leftover browser cookie.

                The CacheClear extra deletes *all* the files in the core/cache directory, but it should only be used as a last resort.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • discuss.answer
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Quote from: lettis at Feb 03, 2013, 06:16 PM
                  Hi Susan and Opengeek,

                  we now could solve the problem. The reason was our cache. Although we used clear cache by Ctrl+Shift+k (I am not sure if this is the same as clearing the cache by Menu->Site->Clear Cache) the file has not been deleted. We now did this manually by ftp and now everything is fine.

                  Because of this trouble we would like to ask if it is normal that 'Clear Cache' in Modx doesn´t clear the complete cache or is this a misconfiguration of our system?

                  Thanks a lot again for your help.
                  Letti
                  This is not a problem and is by design in MODX 2.2. As BobRay said, the system_settings and context_settings are regenerated by actions in the manager. This was done intentionally to relieve the burden from the first request to the front-end Context.
                    • 34178
                    • 212 Posts
                    Thank you very much Bob and opengeek, for these further informations. Very helpful.

                    Letti