New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi
    I am running a website at a swiss hosting provider. The provider updated php-Version to 5.3.16 and set the magic-quotes_gpc setting to on. They will not set it to off and will not downgrade to Version 5.2.

    The hosted website uses MaxiGallery and now there is backslahes all over!! My client needs MaxiGallery to put on a new auction soon. Is there any way to trick the hosting provider and set the setting to off?

    Thanks for helping me.
    Markus
    • Wow, that sucks. Time to look at other options.

      How long do you have till the auction? Here's a thought...

      A quick move might be worth the effort. Try MODX Cloud for 15 days, move the site to a dev cloud and show the client how simple it can be. Then move to a new production cloud.

      Setting up a standard server might be a lot of work with your time frame in mind, but it wouldn't be with cloud. Email would take some extra time though.
        Frogabog- MODX Websites in Portland Oregon
        "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
        Having server issues? These guys have MODX Hosting perfected - SkyToaster
      • You can try either of the following directives in the .htaccess file:

        php_flag magic_quotes_gpc Off
        php_value magic_quotes_gpc Off


        If those don't work, you can try putting a php.ini file in the /manager/ directory with the directive:

        magic_quotes_gpc = Off


        The ironic thing about this is that the setting is removed altogether in PHP 5.4

          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
        • Hi Susan

          Thanks for your help, both ways not working at all.

          The .htaccess solution gave me a "500 internal server error" and the php.ini solution didn't change the situation with the backslashes...

          Maybe I have to change the hosting company, by the way this is the biggest in Switzerland!!!

          Any other solutions?
          Thanks
          Markus


          Quote from: sottwell at Dec 22, 2012, 12:43 PM
          You can try either of the following directives in the .htaccess file:

          php_flag magic_quotes_gpc Off
          php_value magic_quotes_gpc Off


          If those don't work, you can try putting a php.ini file in the /manager/ directory with the directive:

          magic_quotes_gpc = Off


          The ironic thing about this is that the setting is removed altogether in PHP 5.4

          • Are you talking about Nextron? I have a long-time client with them, and I see they've upgraded and magic_quotes_gpc is on, so it's probably them.

            I added the line
            php_flag magic_quotes_gpc Off

            to the .htaccess, and it did the trick.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
            • No it is green.ch and they don't want to downgrade to php 5.2 or set the setting to off. What can I do?

              Quote from: sottwell at Dec 23, 2012, 05:44 PM
              Are you talking about Nextron? I have a long-time client with them, and I see they've upgraded and magic_quotes_gpc is on, so it's probably them.

              I added the line
              php_flag magic_quotes_gpc Off

              to the .htaccess, and it did the trick.
              • You can check its value in the Manager in Reports, System Info, and the phpinfo link. Scroll down a bit in the PHP Core section, and you should see that magic_quotes_gpc has a local value of "off", and the master value is "on".
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                • I know this, the provider told me on the phone that they will not change the settings! So do I have to change the provider and take the site to a new hoster?

                  here the link to the phpinfo: http://www.rusterholtz.ch/phpinfo.php

                  Quote from: sottwell at Dec 23, 2012, 05:48 PM
                  You can check its value in the Manager in Reports, System Info, and the phpinfo link. Scroll down a bit in the PHP Core section, and you should see that magic_quotes_gpc has a local value of "off", and the master value is "on".
                  • Ah, sorry. If neither of the directives work in the .htaccess, and adding a custom php.ini in the /manager/ folder didn't work, then unless you can change hosting you'll have to figure out a plugin or something similar to remove the extraneous slashes.
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                      • Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org