On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello all.

    I installed the Ace code editing plugin, and now manager can't load any of its pages. I have menus and the left sidebar, just nothing in the main content area. As you can imagine, this is an issue because I can't access any of the package management features to disable anything.

    In the Chrome Console window, I see:

    Failed to load resource: the server responded with a status of 400 (Bad Request) http://[mydomain.com]/manager/min/index.php?f=/manager/components/ace/assets/ace/ace.js,
    /manager/components/ace/assets/modx.texteditor.js,
    /manager/assets/modext/util/datetime.js,/manager/assets/modext/widgets/element/modx.panel.tv.renders.js,
    /manager/assets/modext/widgets/resource/modx.grid.resource.security.local.js,
    /manager/assets/modext/widgets/resource/modx.panel.resource.tv.js,
    /manager/assets/modext/widgets/resource/modx.panel.resource.js,
    /manager/assets/modext/sections/resource/update.js
    Uncaught TypeError: undefined is not a function 


    When I go into the server to look for these files, they don't exist.

    Any suggestions on how to fix this issue?

    Thanks,

    Andrew
    • Try getting into the database, and in the site_plugins table find the Ace plugin and set its disabled field to 1. That should allow you to access the manager again.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • That worked after I cleared out core/cache. Any ideas on what might have caused it? I did get some red text in the console when installing it but at the end of the dialog it said the install was successful. I'm guessing files never got copied.
        • It does appear that some files are missing or corrupted.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • Thanks sottwell, that got me passed the initial problem, which was after an update to Ace 1.5.0, which changed to folder location from /manager/assets/... back to /assets/.... Problem appears to be in picking up the new location. Could not find anything in system settings, so I'll look elsewhere.

            http://TLD/manager/min/index.php?
            f=/manager/assets/components/ace/ace/ace.js,
            /manager/assets/components/ace/modx.texteditor.js,
            /assets/components/gallery/js/mgr/gallery.js,
            /assets/components/gallery/js/mgr/tree.js,
            /manager/assets/modext/widgets/core/modx.grid.local.property.js,
            /manager/assets/modext/widgets/element/modx.grid.element.properties.js,
            /manager/assets/modext/widgets/element/modx.grid.template.tv.js,
            /manager/assets/modext/widgets/element/modx.panel.template.js,
            /manager/assets/modext/sections/element/template/update.js


            Best I can figure is core/components/ace/model/ace/ace.class.php did not get updated, so I copied one from another install. Seems to work so far.