We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22303 MODX Staff
    • 10,725 Posts
    Your setup did not write the config file properly. You should start fresh with an empty database in order to install properly.
      • 16899
      • 284 Posts
      Quote from: opengeek at Dec 06, 2012, 09:09 AM
      Your setup did not write the config file properly. You should start fresh with an empty database in order to install properly.

      But i did it!!! Then i tried with the old conf file and it works but with some errors!!!

      Warning: MagpieRSS: Failed to parse RSS file. (Reserved XML Name at line 1, column 38) in C:\Program Files\EasyPHP-12.1\www\visitcarvoeiro\core\model\modx\xmlrss\rssfetch.class.php on line 237
      
      Notice: Trying to get property of non-object in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-news.php on line 28
      
      Warning: array_keys() expects parameter 1 to be array, null given in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-news.php on line 28
      
      Warning: Invalid argument supplied for foreach() in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-news.php on line 28
      
      Warning: MagpieRSS: Failed to parse RSS file. (Reserved XML Name at line 1, column 38) in C:\Program Files\EasyPHP-12.1\www\mysite\core\model\modx\xmlrss\rssfetch.class.php on line 237
      
      Notice: Trying to get property of non-object in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-security.php on line 25
      
      Warning: array_keys() expects parameter 1 to be array, null given in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-security.php on line 25
      
      Warning: Invalid argument supplied for foreach() in C:\Program Files\EasyPHP-12.1\www\mysite\manager\controllers\default\dashboard\widget.modx-security.php on line 25
      [ed. note: legues last edited this post 13 years, 9 months ago.]
        • 40092
        • 265 Posts
        I have just tried the same upgrade and got exact the same errors. Line 13, 14 and 89 parse error because no '' around the curlybraces. And the the XPDO error on line 1823. Must i report something somewhere?
          • 40092
          • 265 Posts
          Those errors are from the newsfeed, a lot of people have them. A workaround is to temporarily unload them.
            • 16899
            • 284 Posts
            Quote from: thapriest86 at Dec 06, 2012, 10:19 AM
            Those errors are from the newsfeed, a lot of people have them. A workaround is to temporarily unload them.

            Yes... i did check my other sites and it seems that the Modx on the Manager Dashboard just disappeared!!!
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              The feeds have been fixed (my fault, sorry).
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 40092
                • 265 Posts
                Bad karma is on your way, Mark. :-p

                How about the upgrade failure, do i have to report that somewhere? [ed. note: thapriest86 last edited this post 13 years, 9 months ago.]
                  • 18373 ☆ A M B ☆
                  • 3,141 Posts
                  I'm not sure what would cause the issue, other than an very botched install. The config file should be replacing all {stuff} values with actual values.

                  I'd reupload all the files and run install again. Take a backup of the db beforehand.
                    Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                    Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                    • 40092
                    • 265 Posts
                    It's on localhost and tried already. Replacing new config file with the old one seems to work. But, it's quite the coincidence that Legues and i get exactly the same errors after upgrading.

                      • 16899
                      • 284 Posts
                      Now it´s perfect!!! I just download MODX again and did a fresh install... as always... and it´s working normally!!! smiley
                      And yes, i´m almost 100% sure that the feeds error was creating all these problems in my instalation!!! Problem SOLVED!!! wink Thanks to all of you guys, who tried to helped me!!! smiley