We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 41583
    • 29 Posts
    yes sounds like it. They might of done updates or disabled some PHP function you require. I know it requires Curl
      • 4292
      • 15 Posts
      If somebody know- url http://rest.modx.com/extras/ alive or not?
      I can't link to this url.
      If I do that I have a message:

      The page you were looking for doesn't exist.
      You may have mistyped the address or the page may have moved.
      


      So may be this is a problem why i cant update/download packages?

      My host provider said me to ask a question to developers about this url and 199.47.222.137 sever- does they working?

      So, i have no idea what to do. Please help smiley
        • 41583
        • 29 Posts
        its working, I am guessing that is standard error page displayed as they won't want anyone just browsing to it via a normal browser. I was thinking the same thing when I had the issue.
          • 4292
          • 15 Posts
          I have three sites on this shared hosting server (Revo 2.2.2 and 2 Revo 2.2.6) and all sites have the same problem.

          (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modx.com/extras/
          (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modx.com/extras/
          


          About cURL:
          cURL support 	enabled
          cURL Information 	libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5 
          


          For experiment I am installed MODx Revo 2.2.6 on my local server Xampp and all is working- no ERRORs in site system log.

          Info from Reports>System Information:
          System 	Linux 2.6.18-308.24.1.el5 #1 SMP Tue Dec 4 17:43:34 EST 2012 x86_64
          Build Date 	Mar 27 2012 23:17:42
          Configure Command 	'./configure' '--with-config-file-path=/usr/local/etc/' '--with-curl' '--enable-ftp' '--with-iconv=/usr/local/lib' '--enable-mbstring' '--enable-shmop' '--enable-sockets' '--with-mysqli=/usr/local/mysql/bin/mysql_config' '--with-mysql=/usr/local/mysql' '--with-gd' '--enable-gd-native-ttf' '--with-t1lib' '--with-freetype-dir' '--with-jpeg-dir=/usr/local/lib' '--with-mssql' '--with-zlib' '--with-pcre-regex' '--enable-session' '--with-regex' '--enable-xml' '--enable-simplexml' '--enable-xmlreader' '--enable-libxml' '--enable-tokenizer' '--with-xsl' '--enable-dom' '--with-pear=/usr/local/pear' '--with-tidy=/usr' '--with-config-file-path=/usr/local/etc' '--enable-soap' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-fastcgi' '--enable-force-cgi-redirect' '--with-mcrypt' '--enable-ctype' '--enable-spl' '--with-openssl' '--enable-dbase' '--with-imap' '--with-kerberos' '--with-imap-ssl' '--enable-pdo' '--with-pdo-sqlite' '--with-sqlite' '--with-pdo-mysql=/usr/local/mysql' '--enable-zip' '--with-gettext' '--enable-exif' '--enable-pcntl' '--enable-calendar' '--with-mhash' '--enable-bcmath' '--with-xmlrpc' '--enable-wddx' '--with-bz2' '--with-config-file-path=/usr/local/etc/'
          Server API 	CGI/FastCGI
          Virtual Directory Support 	disabled
          Configuration File (php.ini) Path 	/usr/local/etc/
          Loaded Configuration File 	
          Scan this dir for additional .ini files 	(none)
          additional .ini files parsed 	(none)
          PHP API 	20041225
          PHP Extension 	20060613
          Zend Extension 	220060519
          Debug Build 	no
          Thread Safety 	disabled
          Zend Memory Manager 	enabled
          IPv6 Support 	enabled
          Registered PHP Streams 	https, ftps, compress.zlib, compress.bzip2, php, file, data, http, ftp, zip
          Registered Stream Socket Transports 	tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
          Registered Stream Filters 	zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed 
          
          [ed. note: bullet last edited this post 13 years, 9 months ago.]
            • 4292
            • 15 Posts
            Good news everyone- my problem is solved.
            From my hoster:

            ... network address is blocked by modx.com. Now we discuss this problem and waiting for unlock during this month ...
            So I moved my account to other server and packages downloading/updating is normalized.
            Thx for help.
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              Network address blocked by MODX.com? Interesting. Sounds like you're sorted for now, but feel free to shoot us a message at [email protected] including details like server IP(s), host etc, and the server guys can look into it then.
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 4292
                • 15 Posts
                Thx for response. My hoster said that they already discussed this problem with MODx. I hope it's true )
                  • 28042 ☆ A M B ☆
                  • 24,524 Posts
                  Unfortunately persistent spammers or hacking attempts can cause whole swathes of IP blocks to be banned, affecting completely innocent customers of the same ISP who are randomly assigned the banned IP addresses.
                    Studying MODX in the desert - http://sottwell.com
                    Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                    Join the Slack Community - http://modx.org
                    • 4292
                    • 15 Posts
                    Thanks, I am understand.