We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 5340
    • 1,624 Posts
    UPDATE 5:

    I fixed the gallery as well. I don't know why but during the upgrade the files were not properly transferred. Because some files were transferred I assumed everything was ok.

    UPDATE 4:

    Seems like files/folders with permissions bigger than 755 were not accessible. This fixes the Redirector and Batcher problem but not the Gallery. Accessing the gallery in the manager gives me this error:
     [2012-12-01 21:03:47] (ERROR @ /site/assets/components/gallery/connector.php) Error 42S22 executing statement: 
    Array
    (
        [0] => 42S22
        [1] => 1054
        [2] => Unknown column 'galItem.url' in 'field list'
    )


    Looking into it.




    UPDATE 3:

    This is nuts! Seems like no file inside assets/components folder can be accessed with a browser. I created a file test.php inside assets/components and I can't access it. Permissions are 777 for assets and the file.



    UPDATE 2:

    After changing $modx_assets_url= '/assets/'; to $modx_assets_url= '/site/assets/'; I get
    "404 not found" on http://mysite.com/site/assets/components/redirector/connector.php and an error window appears showing the "not found" page of the site.

    File and folder permission seem OK; 755 and 777 in some cases. Weird stuff.

    UPDATE:

    Seems like the manager is requesting the controller at the wrong location.

    http://mysite.com/assets/components/batcher/connector.php
    and not
    http://mysite.com/site/assets/components/batcher/connector.php

    I double checked the paths and could not see anything wrong with them.


    Hi,

    I managed to upgrade modx to 2.2.5 and the only problem I could not fix and figure out is why the components I have installed are empty.

    1. Batcher is empty. No modx documents are shown
    2. Gallery shows the albums but not the images
    3. Redirector is empty. No rules are shown but I checked the database and they are there. When I try to add a rule nothing happens; connector.php returns nothing.

    The way I upgraded the site was to duplicate the live one in a folder, duplicate the db, copied the files and ran the installer.

    Any ideas why everything works as expected except the components?
    Thanks


    PS: cache was cleared, sessions were flushed







    [ed. note: cipa last edited this post 13 years, 10 months ago.]
      • 10208 ☆ A M B ☆
      • 1,780 Posts
      You may need to update more config files. Also, check the workspaces table path, and also look in system settings for each extra that isn't working and check for incorrect paths.

      Look about halfway down this page at the rtfm for all the files to check and change paths if needed.
      http://rtfm.modx.com/display/revolution20/Moving+Your+Site+to+a+New+Server
        Frogabog- MODX Websites in Portland Oregon
        "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
        Having server issues? These guys have MODX Hosting perfected - SkyToaster
        • 5340
        • 1,624 Posts
        Did that. Seems like I can't access anything inside the components folder. Weird
          • 10208 ☆ A M B ☆
          • 1,780 Posts
          Time to try a reinstall with a freshly unpacked 2.2.5.zip. Run it in upgrade mode with a fully cleared core/cache folder (log out of manager).

          Just to check, you're not using FTP to merge the unpacked files are you? FTP is known to miss or corrupt files during transfer. Best to unpack the .zip file on the server itself.

          Also, is there anything in the MODX error log?
            Frogabog- MODX Websites in Portland Oregon
            "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
            Having server issues? These guys have MODX Hosting perfected - SkyToaster
            • 5340
            • 1,624 Posts
            Hi,

            See the last update. Weird stuff. The zip was unpacked using the host's package manager. The upgrade process was not that easy and probably somewhere in the process I change the permissions to 777 or 775 and for some weird reason this broke the Batcher and Redirector components. Still looking into why the gallery is not working as expected.

            Thx
              • 10208 ☆ A M B ☆
              • 1,780 Posts
              It won't hurt to run setup again, just in case. So there's nothing in the MODX log?

              Have you reinstalled Gallery? I'm mildly curious if reinstall even works. I've seen recently with server moves and upgrades that the packages are there, but do not install or reinstall.
                Frogabog- MODX Websites in Portland Oregon
                "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
                Having server issues? These guys have MODX Hosting perfected - SkyToaster
                • 5340
                • 1,624 Posts
                I reinstalled 3 times, reinstall gallery and now I get. I will try reinstalling one more time


                "/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg" does not exist in file "phpthumb.class.php" on line 3647
                    [22] => setCacheDirectory() starting with config_cache_directory = "/home/mysite/public_html/site/assets/components/gallery/cache" in file "phpthumb.class.php" on line 919
                    [23] => setting config_cache_directory to realpath(/home/mysite/public_html/site/assets/components/gallery/cache) = "/home/mysite/public_html/site/assets/components/gallery/cache" in file "phpthumb.class.php" on line 947
                    [24] => SetCacheFilename() _src set from md5($this->sourceFilename) "/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg" = "7821e245d863fbbc62bbf46426b63f0c" in file "phpthumb.class.php" on line 3077
                    [25] => SetCacheFilename() _par set from md5(_farC_zc1_h100_w100_dpi150_q75) in file "phpthumb.class.php" on line 3110
                    [26] => starting ExtractEXIFgetImageSize() in file "phpthumb.class.php" on line 2897
                    [27] => GetImageSize("/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg") failed in file "phpthumb.class.php" on line 2920
                    [28] => $this->useRawIMoutput=true after checking $UnAllowedParameters in file "phpthumb.class.php" on line 1232
                    [29] => phpThumb_tempnam() returning "/home/mysite/public_html/site/assets/components/gallery/pThumbia3Iwg" in file "phpthumb.class.php" on line 3861
                    [30] => ImageMagickSwitchAvailable(thumbnail) = 1 in file "phpthumb.class.php" on line 1189
                    [31] => ImageMagickSwitchAvailable(density) = 1 in file "phpthumb.class.php" on line 1189
                    [32] => GetImageSize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) FAILED with error "<br />
                <b>Warning</b>:  getimagesize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory in <b>/home/mysite/public_html/site/core/model/phpthumb/phpthumb.class.php</b> on line <b>1312</b><br />
                " in file "phpthumb.class.php" on line 1318
                    [33] => GetImageSize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) failed in file "phpthumb.class.php" on line 1460
                    [34] => Remaining $this->fltr after ImageMagick: (array(0) { } ) in file "phpthumb.class.php" on line 1807
                    [35] => ImageMagickSwitchAvailable(quality;interlace) = 1 in file "phpthumb.class.php" on line 1186
                    [36] => ImageMagick called as (convert -density 150 -thumbnail 100x100 -quality 75 -interlace line  "/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg[0]" jpeg:"/home/mysite/public_html/site/assets/components/gallery/pThumbia3Iwg" 2>&1) in file "phpthumb.class.php" on line 1826
                    [37] => ImageMagick failed with message (convert: unable to open image `/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg': No such file or directory @ error/blob.c/OpenBlob/2617.
                convert: no images defined `jpeg:/home/mysite/public_html/site/assets/components/gallery/pThumbia3Iwg' @ error/convert.c/ConvertImageCommand/3018.) in file "phpthumb.class.php" on line 1834
                    [38] => ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 2927
                    [39] => SetOrientationDependantWidthHeight() starting with ""x"" in file "phpthumb.class.php" on line 2876
                    [40] => SetOrientationDependantWidthHeight() setting w="100", h="100" in file "phpthumb.class.php" on line 2892
                    [41] => EXIF thumbnail extraction: (size=0; type=""; 0x0) in file "phpthumb.class.php" on line 2979
                    [42] => starting SourceImageToGD() in file "phpthumb.class.php" on line 3229
                    [43] => $this->useRawIMoutput=true after checking $UnAllowedParameters in file "phpthumb.class.php" on line 1232
                    [44] => phpThumb_tempnam() returning "/home/mysite/public_html/site/assets/components/gallery/pThumbQUICKY" in file "phpthumb.class.php" on line 3861
                    [45] => ImageMagickSwitchAvailable(thumbnail) = 1 in file "phpthumb.class.php" on line 1189
                    [46] => ImageMagickSwitchAvailable(density) = 1 in file "phpthumb.class.php" on line 1189
                    [47] => GetImageSize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) FAILED with error "<br />
                <b>Warning</b>:  getimagesize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory in <b>/home/mysite/public_html/site/core/model/phpthumb/phpthumb.class.php</b> on line <b>1312</b><br />
                " in file "phpthumb.class.php" on line 1318
                    [48] => GetImageSize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) failed in file "phpthumb.class.php" on line 1460
                    [49] => Remaining $this->fltr after ImageMagick: (array(0) { } ) in file "phpthumb.class.php" on line 1807
                    [50] => ImageMagickSwitchAvailable(quality;interlace) = 1 in file "phpthumb.class.php" on line 1186
                    [51] => ImageMagick called as (convert -density 150 -thumbnail 100x100 -quality 75 -interlace line  "/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg[0]" jpeg:"/home/mysite/public_html/site/assets/components/gallery/pThumbQUICKY" 2>&1) in file "phpthumb.class.php" on line 1826
                    [52] => ImageMagick failed with message (convert: unable to open image `/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg': No such file or directory @ error/blob.c/OpenBlob/2617.
                convert: no images defined `jpeg:/home/mysite/public_html/site/assets/components/gallery/pThumbQUICKY' @ error/convert.c/ConvertImageCommand/3018.) in file "phpthumb.class.php" on line 1834
                    [53] => starting ImageCreateFromFilename(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) in file "phpthumb.class.php" on line 3152
                    [54] => empty $filename or GetImageSize(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) failed in file "phpthumb.class.php" on line 3201
                    [55] => Populating $rawimagedata in file "phpthumb.class.php" on line 3209
                    [56] => cannot fopen(/home/mysite/public_html/site/assets/components/gallery/files/6/1722.jpg) in file "phpthumb.class.php" on line 3212
                    [57] => Not using EXIF thumbnail data because $this->exif_thumbnail_data is empty in file "phpthumb.class.php" on line 3278
                    [58] => $this->gdimg_source is still empty in file "phpthumb.class.php" on line 3330
                    [59] => ImageMagickThumbnailToGD() failed in file "phpthumb.class.php" on line 3332
                    [60] => phpThumb() v1.7.9-200712090829
                
                Unknown image type identified by "" () in SourceImageToGD()[3444] in file "phpthumb.class.php" on line 3647
                    [61] => SourceImageToGD() failed in file "phpthumb.class.php" on line 323
                )
                

                  • 28042 ☆ A M B ☆
                  • 24,524 Posts
                  Did you completely remove Gallery, or just un-install it?
                    Studying MODX in the desert - http://sottwell.com
                    Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                    Join the Slack Community - http://modx.org
                    • 5340
                    • 1,624 Posts
                    I don't remember removing it but I upgraded it and reinstalled it a few times. It turned out some pictures were missing or were not transferred properly. Also my friend managed to remove some of the pictures using the FTP instead of using the gallery module. Lesson learned smiley