Hello. I noticed something that i think has to do with this plugin and the snippet sitemap v.1.0.11-pl. When the plugin is disabled,sitemap works correctly and the xml appears as it should be. However,when i have the Websignup_activate_plugin enabled, i get an error on the page which says:
"error on line 1 at column 1: Document is empty" and after i refresh the page the error message changes to:
"error on line 1 at column 6: XML declaration allowed only at the start of the document".
Any clues why?
I think you need to exclude the activation document from being retrieved for the sitemap. From the documentation you'll have to create a TV named "hide" and set its value on the activation document to "1":
[!SiteMap? &excludeTemplates=`blank,hidden` &excludeTV=`hide`!]
outputs a sitemap in Sitemap Procotol format;
will exclude documents using blank and hidden templates;
will exclude documents with the template variable named hide set to 1;
Yeah,i had already tried that,but to no avail. Let me tell you specifically what i have tried so far:
1)I created a blank template and placed the call [!SiteMap?&format=`sp`!] in it and then set that template only to the SiteMap resource. Problem persisted.
2)I created a TV named "hide" with input number and set its value to 1 in the activation page. Afterwards i placed the &excludeTV=`hide` in my Sitemap call. Since that didn't solve it, i changed the input type of the TV (e.g.text),but still nothing.
3)I removed the <+websignup_activate_output+> placeholder and deleted the activation page,but still nothing. I also deleted various snippets and disabled modules and plugins and yet,the problem remained.
4)I changed the $https_activation_url = FALSE; to TRUE but still nothing.
5)ONLY when i disabled the Websignup_activate_plugin did the sitemap appear normally.
I think that the plugin is somehow inserting a blank line before the start of the XML file. There was another small issue some time ago,but i didn't post it because i thought it didn't matter:
When the plugin was activated,it kinda pushed my top <div> (header) a bit downwards. I fixed that just by playing a little bit with margins and padding in my css file,so i didn't think that it was important to mention. But now i think that's where the source of the problem lies. If a blank line is somehow inserted via the plugin, then it stands to reason that the xml would be erroneus. Any ideas on that?
The plugin only affects the placeholder on the activation page, so there has to be another issue(s) at work here which is influencing your layout. Do you have a link (pm if its private) so I can see the page source?
As far as the sitemap, the activation document should not even be indexed, I see in the snippet docs that you can exclude docs another way using a TV named "changefreq" and set its value to "exclude":
+ Document will be excluded from sitemap when changefreq parameter equals 'exclude'.
I'm sure that can be arranged, I'll tinker around with it today and see what I can come up with
I updated the zip attached to the first post in this thread with the newest version ( 12232012 ).
Added 2 new settings which make it possible to:
pre-populate the activation code field
$print_activation_code = TRUE;
hide the activation field
$hide_activation_field = TRUE;
* see the README.txt for upgrade / install instructions