We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10378
    • 375 Posts
    Hello,

    We are running a large MODx Revo based portal with about 5000 resources. The site is divided into 4 contexts reachable through 4 different domains. Each context has it's own news container (Articles plugin). We are routing between these contexts by the superb ContextRouter plugin by Mark Hamstra.

    MODx Revo 2.2.5-pl

    Since the site went live - the error log is full (1,9 MB) of entries like this:

    ...
    [2012-11-20 09:54:20] (WARN @ /index.php) `3026` was requested but no alias was located.
    [2012-11-20 09:54:20] (WARN @ /index.php) `3025` was requested but no alias was located.
    [2012-11-20 09:54:20] (WARN @ /index.php) `3024` was requested but no alias was located.
    [2012-11-20 09:54:20] (WARN @ /index.php) `3023` was requested but no alias was located.
    [2012-11-20 09:54:20] (WARN @ /index.php) `3022` was requested but no alias was located.
    [2012-11-20 10:02:50] (WARN @ /index.php) `2054` was requested but no alias was located.
    [2012-11-20 10:02:50] (WARN @ /index.php) `2053` was requested but no alias was located.
    [2012-11-20 10:02:50] (WARN @ /index.php) `2052` was requested but no alias was located.
    [2012-11-20 10:02:51] (WARN @ /index.php) `2051` was requested but no alias was located.
    [2012-11-20 10:02:51] (WARN @ /index.php) `2050` was requested but no alias was located.
    [2012-11-20 10:02:51] (WARN @ /index.php) `2049` was requested but no alias was located.
    [2012-11-20 10:02:51] (WARN @ /index.php) `2048` was requested but no alias was located.
    [2012-11-20 10:18:54] (WARN @ /index.php) `24` was requested but no alias was located.
    [2012-11-20 10:28:16] (WARN @ /index.php) `2849` was requested but no alias was located.
    [2012-11-20 10:28:16] (WARN @ /index.php) `2848` was requested but no alias was located.
    ...
    


    I can't find any problem so far - and it seems all resources are reachable.
    What's strange is the fact, that I cant believe that all of these resource documents are already clicked in frontend.
    I think it's the google bot indexing the whole site. But why this warning?

    What can be done to prevent this?

    Greetings,
    Martin
      Freelancer @bitego http://www.bitego.com
      ---
      GoodNews - one of the most advanced and integrated Group Mailer premium add-ons for MODX Revolution!
      More infos here: http://www.bitego.com/extras/goodnews/
      • 332
      • 23 Posts
      Hi Martin, just ran into this same issue on an upgrade from 2.2.4 to 2.2.15. Do u recall what your solution might have been? Thanks,
      Anthony
        • 3749
        • 24,544 Posts
        Do you have SiteCheck? I'd be curious to know what it reports.

        http://bobsguides.com/sitecheck-promo.html

          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 332
          • 23 Posts
          Hi Bob, thanks, I just purchased and ran it. I did get an time zone error that came up, but the interesting one was when I tested Resources and INtersects, both gave me timeout messages like the below:

          Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 81 bytes) in /var/www/MYDOMAIN.com/htdocs/core/xpdo/xpdo.class.php on line 1424
            • 332
            • 23 Posts
            Also, not sure if its related, but when I right click on a resource in the left tree, View Resource is not available (not showing). When I have the resource in the edit state and click the "View" button, it opens a new blank window, and shows about:blank in the window. anyone any ideas?
              • 3749
              • 24,544 Posts
              Did you try running it on just Resources or just intersects?

              How many resources on the site?

              Do you know what memory_limit is set to?
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 332
                • 23 Posts
                Yes, just Resources test timed out. So did the Just Intersects. The Memory limit is 128MB, so thats not the issue.

                I checked that the error page and unauthorized page are set to my homepage for testing. I clear the error log, reload my home page, and I'll get:

                [2014-08-14 17:28:46] (WARN @ /index.php) `1096` was requested but no alias was located.
                [2014-08-14 17:28:46] (WARN @ /index.php) `1096` was requested but no alias was located.

                in the error log
                  • 3749
                  • 24,544 Posts
                  Try this: Log out. Go into the database in PhpMyAdmin. In the modx_site_content table, look up the resource with 1096 in the 'id' column. Check the parent field and the alias field. Set the parent to 0 and the alias to the pagetitle but with just a-z and hyphens.

                  Delete all files in the core/cache directory before logging back in.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 332
                    • 23 Posts
                    Thanks Bob, I tried but no luck. It turns out these resources showing up (1096) are resources related to Login, when I remove my Login form from the homepage and the forgot pw link, etc, the errors dont come back when the home page is loaded.

                    Another part of my site is a property search through a boatload of resources, and that page returns similar errors but with different resource values, such as:

                    [2014-08-14 18:08:41] (WARN @ /connectors/resource/index.php) `562` was requested but no alias was located.
                    [2014-08-14 18:08:41] (WARN @ /connectors/resource/index.php) `430` was requested but no alias was located.
                    [2014-08-14 18:08:41] (WARN @ /connectors/resource/index.php) `431` was requested but no alias was located.
                    [2014-08-14 18:08:41] (WARN @ /connectors/resource/index.php) `432` was requested but no alias was located.
                    [2014-08-14 18:08:41] (WARN @ /connectors/resource/index.php) `535` was requested but no alias was located.

                    etc
                      • 3749
                      • 24,544 Posts
                      OK, I think I see what's happening. The uri field of the resources did not get upgraded. If you turn off FURLs, then turn them back on again, it should refresh the uri fields. If that doesn't work, this utility snippet should:
                      $docs = $modx->getCollection('modResource');
                      foreach ($docs as $doc) {
                          $doc->save();
                      }
                      return '<h3>Finished!</h3>';


                      As an alternative, you can manually save each resource listed in the error messages.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting