⚠️ Urgent! Active Attacks on MODX Revolution Sites Below Revolution 2.6.5
Subscribe: RSS
  • Update: upgrade to 2.2.5-pl fixed this issue.

    I've tried installing and reinstalling Articles (latest version and latest release version of Modx 2.2.4-pl)

    While I can create an articles container and an article, I can't get the article to display in the manager,but I can see it when I view the articles container (view it on the site). The articles grid is just blank, but there is an article (see attached screenshot).

    I do have this in the error log but I don't know how to fix it:

    [2012-10-02 15:59:57] (ERROR @ /connectors/resource/index.php) Could not load class: ArticlesContainer from mysql.articlescontainer.

    Ideas? Thanks
    [ed. note: aesop1 last edited this post 6 years ago.]
    • For what it is worth, an update. Tried reinstalling Articles again and received this error before "successful install" message (but it still isn't showing the articles grid within the manager):

      xPDOVehicle validator failed: type php (/home/navisway/public_html/staging/core/packages/articles-1.6.3-pl/xPDOTransportVehicle/155df8c3d6333bc1aa777d6ed1cfb81a.validate.archivist.validator)
      Could not validate vehicle: Array ( [license] => GNU GENERAL PUBLIC LICENSE Version 2, June 1991 -------------------------- Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed. Preamble -------- The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too. When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things. To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it. For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have.
      [truncated ...]
      - [#6161] Fix issue with changing article row chunk - [#6160] Remove template change reloading for Article types - Custom UI for article posting - Container-specific settings - Integrated RSS feeds with customizable URLs - Integrated Quip commenting - Automatic archiving of Articles - Integrated tagging - Easy templating for containers and articles - Initial release. [signature] => 155df8c3d6333bc1aa777d6ed1cfb81a [initialConfig] => [object Object] [text] => Continue [id] => package-install-btn [hidden] => false [handler] => function (va){ var g = Ext.getCmp('modx-package-grid'); if (!g) return false; var r = g.menu.record.data ? g.menu.record.data : g.menu.record; var topic =
      • Happily, the upgrade to 2.2.5-pl fixed this issue. Closed.
        • I have the same issue, just installed 2.2.5 but still not displaying the articles.
          Even with the default template.
          • Edit: Removed all packages and re-installed all the add-ons. Its now working again.
            • Yes, the fragility of the Articles add-on bothers me. I appreciate the work that went into it and its functionality, but when it breaks I have no real clue why it breaks and the solution of re-installing add-ons seems to be kind of fortuitous.
              • Same problem

                +

                I get always the following message when I "create Articles here":

                Unexpected token '<':
                Internal Server Error
                The server encountered an internal error or misconfiguration and was unable to complete your request.
                Please contact the server administrator, postmaster@XXXX and inform them of the time the error occurred, and anything you might have done that may have caused the error.
                More information about this error may be available in the server error log.
                • Had the same problem.. upgrading didn't work for me but I found this: http://tracker.modx.com/issues/7774

                  Sure enough.. one of the entries was messing up the display. Edited the content in the database and now it functions!
                  • Just had the same problem with a TradeMark symbol. Edited the database directly and that worked.
                      ...

                    • I installed the Articles plugin, created a blog.
                      The blog shows up fine and I can create blog posts
                      by right clicking the blog and choose "Write New Article" but what I cant do
                      is manage articles (the dashboard doesn't show any information when I click)
                      or edit the blog in any way (nothing loads).

                      I have cleared both the site cache and my browser cache.
                      MODX 2.2.11 and Articles 1.7.6
                      All of my plugins are up to date.

                      Anyone know what might be wrong?

                      Fixed it.
                      The guidelines for creating a blog not using Articles gives a list of needed extras. Articles needs some of them as adding them fixed this issue.
                      Articles has no such list of dependencies.


                      [ed. note: vholford last edited this post 4 years, 7 months ago.]