I fail to to installa REVO 2.2.4 under windows 7 wamp
I did not find solution in the MODx forum nor others. Here is my situation
After making a blank config.inc.php file I got a blank page.
OS :Windows 7 64b
APACHE : 2.2.17
PHP : 5.5.3
MYSQL : mysqlnd 5.0.7-dev - 091210 - $Revision: 304625 $
From the APACHE log I got the blocking point
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP Fatal error: Class 'xPDODriver_' not found in C:\\wamp\\www\\modx-2.2.4-pl\\core\\xpdo\\xpdo.class.php on line 1821, referer: http://localhost/
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP Stack trace:, referer: http://localhost/
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP 1. {main}() C:\\wamp\\www\\modx-2.2.4-pl\\index.php:0, referer: http://localhost/
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP 2. modX->__construct() C:\\wamp\\www\\modx-2.2.4-pl\\index.php:54, referer: http://localhost/
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP 3. xPDO->__construct() C:\\wamp\\www\\modx-2.2.4-pl\\core\\model\\modx\\modx.class.php:413, referer: http://localhost/
[Sat Sep 29 10:50:55 2012] [error] [client 127.0.0.1] PHP 4. xPDO->getDriver() C:\\wamp\\www\\modx-2.2.4-pl\\core\\xpdo\\xpdo.class.php:334, referer: http://localhost/
Trackin the variale $options in $modx construct class I got the :
Array
(
[cache_key] => default
[cache_handler] => xPDOFileCache
[cache_path] => C:\wamp\www\modx-2.2.4-pl/core/cache/
[table_prefix] =>
[hydrate_fields] => 1
[hydrate_related_objects] => 1
[hydrate_adhoc_fields] => 1
[validator_class] => validation.modValidator
[validate_on_save] => 1
[cache_system_settings] => 1
[cache_system_settings_key] => system_settings
[connections] => Array
(
[0] => Array
(
[dsn] =>
[username] =>
[password] =>
[options] => Array
(
[connection_mutable] => 1
)
[driverOptions] => Array
(
)
)
)
)
Under Wamp php-pdo-mysql is running well.
While running from folder /setup/ I can lauch the creation proceess but no charset visible in the list for the database connexion. After a manual creation of the database I can launch the manager but still a blanck page on the normal site.
Could you please help me to fix the issue ?
-
☆ A M B ☆
- 1,780 Posts
Why did you make a blank config.inc.php file? And where in the MODX file structure did you place it?
When trying to install straight after dowload I got an error message telling that the config file was not found. I read in a forum that was solved by making a blanck config file in the "core/config/" folder.