We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40122
    • 330 Posts
    Hi all,

    Trying to install Revo 2.2.4 but I get an message that it cannot unzip the zipped core.transport.zip file.

    If I unzip it on my desktop and upload the contents I get loads of PHP errors. All permissions are OK.

    Does anyone know whats happening and how to fix? Thanks
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      Could you tell us about your hosting environment?
        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 40122
        • 330 Posts
        CentOS (LAMP)
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          PHP version. Hosting, or your own server? What kind of PHP errors?
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 40122
            • 330 Posts
            The servers being hosted and its running PHP 5.3.2..

            All the PHP errors are 'cant find' errors - probably occurring because the file remains unzipped.
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              The hosting most likely doesn't have the PHP zip libraries installed.

              You may have to install on localhost, then move the installed site to your hosting.

              You also might want to look into using the advanced setup, although I'm not sure if it can unzip its packages using the pclzip libraries it has or not.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 42107
                • 1 Posts
                Hi.
                I think this might be a solution for you:
                - install MODX on local server
                - move all files to destination server
                - change configs and CHMODs
                - re-run SETUP

                Last one might be a little tricky, because You have to choose option "Core package already on server(...)" or similar and this option is disabled by default. To enable it run installation on Firefox and start FireBug. On proper step run below command in FireBug console - document.getElementById("unpacked").disabled=false. After this choose unlocked option and then continue setup. This works fine for me and hope will be helpfull for you also.

                PK