We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 41043
    • 2 Posts
    Hi there! Long time, first time poster... and I am in need of some wisdom.

    I just installed MODX Revo then installed Gallery. Here's what's bothering me:

    When I go in Components > Gallery, a pop-up appears, titled "Error" and indicating "Unexpected token <: " and nothing else.

    Also, for some reason, when I click on any link on the top navigation, it acts as though it removes "manager/" from the URL (exemple: when I click on "Package Management" the link sends me to "http://somegenericwebsitename.com/?a=60" instead of "http://thesamegenericwebsitename.com/manager/?a=60"

    Does this ring any bells?

    I hope these informations can help:

    PHP v. 5.2.17 with CGI API
    Apache v. 2.2.21
    OS: Linux
    MySql v. 5.1.56-log

    MODX Revolution 2.2.4-pl (traditional)
    Packages installed:
    Gallery
    Wayfinder
    getREsources
    TinyMCE

    EDIT-- On Chrome, the console shows this message:
    Failed to load resource: the server responded with a status of 404 (Not Found)
    http://(...)/assets/components/gallery/connector.php?action=mgr/album/getNodes&id=root

    I checked connector.php's permissions, they're set to 755. I'm completely stumped. [ed. note: dongaspacho last edited this post 14 years, 1 month ago.]
      • 41043
      • 2 Posts
      Fixed it by changing the permissions of /assets and /assets/components from 777 to 755.
        • 3749
        • 24,544 Posts
        Thanks for reporting that. I'm sure it will help someone. smiley


        ------------------------------------------------------------------------------------------
        PLEASE, PLEASE specify the version of MODX you are using.
        MODX info for everyone: http://bobsguides.com/modx.html
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 31104
          • 108 Posts
          I'm so glad you ran into this before I did smiley

          And yes it helped me big time, I really wouldn't have known where to look, I uninstalled gallery like 5 times, deleted cache, re-ran setup and nothing, until I found this post.

          Cheers!

            • 37945
            • 5 Posts
            Thanks dongaspacho, that helped me too. I wonder why this error happen anyway, I thought the assets and assets/compontents/ directories were supposed to be 777 ?
              Marcin Dancewicz
              • 3749
              • 24,544 Posts
              It depends on the host. If the host is running suPHP or something similar, it's 755 for directories and 644 for files. They will reject 777 for directories as insecure.

                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 37945
                • 5 Posts
                Quote from: BobRay at Feb 06, 2013, 04:39 PM
                It depends on the host. If the host is running suPHP or something similar, it's 755 for directories and 644 for files. They will reject 777 for directories as insecure.

                Thank you for this valuable information BobRay, I plan to build many websites on this server so it saved me a lots of hassle!
                  Marcin Dancewicz