Edit: Ok, I managed to fix the problem by restoring an old copy of my config.inc.php, deleting the setup directory, running rsync on the server again, and rerunning setup in the browser.
I'm going to leave the rest of this here in case anyone runs into the same problem, but any idea what went wrong? At one point, when I tried setup, I got the option "Files are already in-place" on the Install options screen. Unchecking that kept the install from bombing where it had been, but in my excitement, I apparently forgot to finish running the install and everything blew up again. *headdesk* The option wasn't there once I deleted and recopied the setup directory.
Filing this under "glad it happened to my own site."
PHP: 5.2.15
MySQL: 5.0.95
I was happily running Revo 2.2.0. After backing up my files and database, I followed my normal SSH upgrade procedure:
wget http://modx.com/download/direct/modx-2.2.4-pl.zip
unzip modx*.zip
cd modx*
rsync -vazr ./ ../public_html/
(The forum seems to be trying to make the above into an actual link. Just ignore the HTML code, that wasn't there.)
So far, so good. I then went to mysite.com/setup/.
1. Kept the default language of "en" and clicked Select.
2. Clicked "Next" to continue.
3. Made sure "Upgrade Existing Install" was selected and clicked "Next."
4. Got the summary page telling me everything was ok, and I clicked "Install."
That gave me the following:
Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 333
Fatal error: Class 'xPDODriver_' not found in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 1821
That left the entire site showing the following error:
Parse error: syntax error, unexpected '{' in /home/myuser/public_html/core/config/config.inc.php on line 13
I can run setup again, but now I get a blank screen after step 2. So looking in the config.inc.php file, I went in and put single quotes around the values on lines 13, 14, and 89.
$config_options = '{config_options}';
$driver_options = '{driver_options}';
...
$modx_cache_disabled= '{cache_disabled}';
Now the entire site is giving me:
Fatal error: Class 'xPDODriver_' not found in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 1821
So I go back and run install again and get:
Warning: require_once(/home/myuser/public_html/setup/includes/drivers/modinstalldriver_{database_type}.class.php) [function.require-once]: failed to open stream: No such file or directory in /home/myuser/public_html/setup/includes/modinstall.class.php on line 91
Fatal error: require_once() [function.require]: Failed opening required '/home/myuser/public_html/setup/includes/drivers/modinstalldriver_{database_type}.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/myuser/public_html/setup/includes/modinstall.class.php on line 91