We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 39251
    • 53 Posts
    Edit: Ok, I managed to fix the problem by restoring an old copy of my config.inc.php, deleting the setup directory, running rsync on the server again, and rerunning setup in the browser.

    I'm going to leave the rest of this here in case anyone runs into the same problem, but any idea what went wrong? At one point, when I tried setup, I got the option "Files are already in-place" on the Install options screen. Unchecking that kept the install from bombing where it had been, but in my excitement, I apparently forgot to finish running the install and everything blew up again. *headdesk* The option wasn't there once I deleted and recopied the setup directory.



    Filing this under "glad it happened to my own site."
    PHP: 5.2.15
    MySQL: 5.0.95

    I was happily running Revo 2.2.0. After backing up my files and database, I followed my normal SSH upgrade procedure:
     wget http://modx.com/download/direct/modx-2.2.4-pl.zip
    unzip modx*.zip
    cd modx*
    rsync -vazr ./ ../public_html/


    (The forum seems to be trying to make the above into an actual link. Just ignore the HTML code, that wasn't there.)

    So far, so good. I then went to mysite.com/setup/.
    1. Kept the default language of "en" and clicked Select.
    2. Clicked "Next" to continue.
    3. Made sure "Upgrade Existing Install" was selected and clicked "Next."
    4. Got the summary page telling me everything was ok, and I clicked "Install."

    That gave me the following:
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 333
    Fatal error: Class 'xPDODriver_' not found in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 1821


    That left the entire site showing the following error:
    Parse error: syntax error, unexpected '{' in /home/myuser/public_html/core/config/config.inc.php on line 13


    I can run setup again, but now I get a blank screen after step 2. So looking in the config.inc.php file, I went in and put single quotes around the values on lines 13, 14, and 89.
    $config_options = '{config_options}';
    $driver_options = '{driver_options}';
    ...
    $modx_cache_disabled= '{cache_disabled}';


    Now the entire site is giving me:
    Fatal error: Class 'xPDODriver_' not found in /home/myuser/public_html/core/xpdo/xpdo.class.php on line 1821


    So I go back and run install again and get:
    Warning: require_once(/home/myuser/public_html/setup/includes/drivers/modinstalldriver_{database_type}.class.php) [function.require-once]: failed to open stream: No such file or directory in /home/myuser/public_html/setup/includes/modinstall.class.php on line 91
    
    Fatal error: require_once() [function.require]: Failed opening required '/home/myuser/public_html/setup/includes/drivers/modinstalldriver_{database_type}.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/myuser/public_html/setup/includes/modinstall.class.php on line 91


      If there's a better way to do it, I'll find it.
      • 3866 ☆ A M B ☆
      • 350 Posts
      Hi there,

      I ran into a similar problem and spent several hours trying to resolve the issue.

      It turned out that the plugin activationemail was the culprit. I uninstalled this and was able to upgrade to 2.2.4.

      Hope that may help others. smiley
        Helen Warner
        Number one pixel!
        Proud to be linked with MODX at Crimson Pixel
        • 3749
        • 24,544 Posts
        @boomerang Were you unable to run Setup and did you see that same error message?


          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 3866 ☆ A M B ☆
          • 350 Posts
          No the messages were different - unfortunately I didn't make a note of exactly what the message was. When I attempted to run setup it took me as far as checking that all files were writable and then as soon as I clicked next there was an error which was to do with a cached file.

          I did try clearing the cache manually but that didn't fix the problem. It turned out to be the activationemail plugin.

          More at https://forums.modx.com/thread/79179/activationemail-plugin-problem-on-upgrade-from-2-2-0-to-2-2-4#dis-post-436498
            Helen Warner
            Number one pixel!
            Proud to be linked with MODX at Crimson Pixel