On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Had to play with this a little bit to get it to work. Have very simply requirements and just wanted to ensure the manager could send out the "forgotten password" email if I ever forgot it. Here were my settings:

    mail_smtp_auth Yes
    mail_smtp_hosts smtp.gmail.com
    mail_smtp_pass [password]
    mail_smtp_port 465
    mail_smtp_prefix ssl
    mail_smtp_user [me@domain.com]
    mail_user_smtp Yes

    The two pieces that tripped me up was the "prefix" (SMTPSecure) -- I was looking around to see where you set it for ssl and just missed this one. The second part was the port -- I was trying 587 until I found a reference to 465.

    At any rate, with these settings I was sending email through Gmail from the manager on my barebones Ubuntu server (ie. doesn't have sendmail).
    • Just a note, this failed for me on localhost until I figured out that Gmail doesn't like to see 'localhost' in an email address or domain name.



      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Use 587 with tls prefix, it works for me...

        587 port is set by default, tls prefix is not. So set 'tls'.
        • Thanks Lord Daedra! Helped me a lot!
            https://www.beautyislife-shop.de - premium make-up!
            https://www.topsterne.de - sell it here!
            ---------------------------------------------------------