On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • 1. I was using 2.0.1-pl and it worked great. Then I tried to test the MIGX-db, so I followed the tutorial:
    http://rtfm.modx.com/display/ADDON/MIGX
    When visit the Component>MIGX, the manager UI was so ugly that made me feel uncomfortable (need some css options for padding space).
    Later I did upgrade MIGX to 2.2.0-pl and after that when I visited pages which were using template with migx-tvs, I got 500 error (which always make me feel doomed). The Component>MIGX page also produced 500 error.
    After all I have to revert to 2.0.1-pl.

    2. Fresh install core 2.2.4-pl and fresh MIGX 2.2.0-pl does have same problems.

    3. Otherwises, I've meet some errors when visit packages management(I think it is not migx related but the core itself). At the time I upgraded core from 2.2.2 to 2.2.4 but the errors are the same
    (ERROR @ /modx/connectors/workspace/packages.php) Could not transfer package archivist-1.2.3-pl.transport.zip to /home/x/htdocs/modx/core/packages/
    ...and many other pkgs
    (ERROR @ /modx/connectors/workspace/packages.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    ...
    

    When I do the fresh core 2.2.4, this isn't replicated.

    Well I think it's a real problem somewhere in the MIGX2.2.0-pl. I'm feeling really bad now because it takes me too much time to test and find out what is going wrong.
    Is there someone else meet the same problems then?
    • I hope bruno17 can look into this topic at weekend.
      • How many resources do you have in your table?

        I get this error if I remove

        &where=`{"published:=":"1"}` from my snippet call or if I set it to 0.

        There should be about 280 results under this condition.

        If I ask for a small number of results, lets say 50 or so everything is fine.

        This might be related to server resources (memory or cpu), but I can't believe that.

        P.S. Note to self: How do I limit/offset results?

          Homepage: pepebe.de | MODX snippets (and other stuff) at github: https://gist.github.com/pepebe
        • Well I'm doing the flat plate for new website, so it's about 10 resources, not many. It's the MIGX error while I even can't edit resources which are using template with migx-tv binding.
          • seems something strange on your installation.
            At the moment I can't guess what goes wrong there.
              -------------------------------

              you can buy me a beer, if you like MIGX

              http://webcmsolutions.de/migx.html

              Thanks!
            • I think at the moment I'll stand using 2.0.1-pl while it's still working. A fresh start of modx with core 2.2.4-pl and migx 2.2.0-pl just doesn't work. It's too bad that I don't have enough experience to debug.