We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15114
    • 102 Posts
    Hi,

    After having migrate on a new server, I try to upgrade MODX (from 2.2.1 to 2.2.4). But I got this kind of error :


    Error updating table for class modResource
    Array
    (
    [0] => 42S21
    [1] => 1060
    [2] => Duplicate column name 'properties'
    )

    Error updating table for class modAction
    Array
    (
    [0] => 42000
    [1] => 1091
    [2] => Can't DROP 'parent'; check that column/key exists
    )

    So, some columns already exist (and some are already droped). I suppose I can ignore these message ?

    But I also have this error :

    The install failed because MODX could not unpack the /[...]/public_html/core/packages/core.transport.zip package. Make sure that the /[...]/public_html/core/packages/core.transport.zip file exists and is writable, and that you have made the /[...]/public_html/core/packages/ directory writable.

    I checked that the specified directories are writeable but that doesn't work better.
    What can I do ?

    Julien
      • 3749
      • 24,544 Posts
      The first set of error messages can be ignored.

      The second error is almost always due to file/directory permissions of ownership of the files. On some servers, you need to set directory permissions to 755 and files to 644.


      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 15114
        • 102 Posts
        Hi

        I try again. The permissions are set to 777. I also tried a new install but the problem is the same.

        I checked the PHP log and I foud that : PHP Warning: ZipArchive::extractTo(/[...]/public_html/core/packages//core/manifest.php): failed to open stream: Permission denied in /[...]/public_html/core/xpdo/compression/xpdozip.class.php on line 142, referer: http://[...]/setup/index.php?action=summary

        But why ? [ed. note: JuTs last edited this post 14 years, 3 months ago.]
          • 3749
          • 24,544 Posts
          Try setting directory permissions to 755 and files to 644. If the host is running suPHP or suExec, it will refuse to use directories set to 777.


          ------------------------------------------------------------------------------------------
          PLEASE, PLEASE specify the version of MODX you are using.
          MODX info for everyone: http://bobsguides.com/modx.html
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 15114
            • 102 Posts
            If I use 755 I got messages of this kind :

            FATAL ERROR: MODX Setup cannot continue.

            Make sure your /[...[/public_html/core/cache directory exists and is writable by the PHP process.

            I see there is an option saying :
            Core Package has been manually unpacked
            (Recommended for installation on shared servers.)
            .
            I could use that but the checkbox is disabled

            Julien
              • 3749
              • 24,544 Posts
              It sounds like an ownership problem with your directories. I've never experienced that, so I can't tell you exactly what to do and it depends on how the server is configured, so you may have to check with your host. Maybe someone else can help.


              ------------------------------------------------------------------------------------------
              PLEASE, PLEASE specify the version of MODX you are using.
              MODX info for everyone: http://bobsguides.com/modx.html


                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting