We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40118
    • 10 Posts
    I'm moving form my localhost to an online location at "staging.xxx.com" using the instructions at http://rtfm.modx.com/display/revolution20/Moving+Your+Site+to+a+New+Server.

    I set my base paths using "/staging.xxx.com/html/" as a base for all required locations.
    I set my urls using "/" as a base on the main config.inc file.
    My http_host is set to xxx.com (or should it be 'staging.xxx.com' ?) in the confic.inc? I tried using 123456.gridserver.com as well, but i get the exact same results.

    Results:

    I get the following when trying to open http://staging.xxx.com/manager ....

    ____________________

    Warning: include_once(/staging.xxx.com/html/model/modx/modx.class.php) [function.include-once]: failed to open stream: No such file or directory in /nfs/c10/h01/mnt/123456/domains/staging.xxx.com/html/manager/index.php on line 50

    Warning: include_once() [function.include]: Failed opening '/staging.xxx.com/html/model/modx/modx.class.php' for inclusion (include_path='.:/usr/local/php-5.3.13/share/pear') in /nfs/c10/h01/mnt/123456/domains/staging.xxx.com/html/manager/index.php on line 50

    Warning: include(/staging.xxx.com/html/error/unavailable.include.php) [function.include]: failed to open stream: No such file or directory in /nfs/c10/h01/mnt/123456/domains/staging.xxx.com/html/manager/index.php on line 51

    Warning: include() [function.include]: Failed opening '/staging.xxx.com/html/error/unavailable.include.php' for inclusion (include_path='.:/usr/local/php-5.3.13/share/pear') in /nfs/c10/h01/mnt/150057/domains/staging.xxx.com/html/manager/index.php on line 51
    Site temporarily unavailable!

    ___________

    Btw, there's an htaccess on server that password protects the html folder from the staging folder location (ie. from '/staging.xxx.com/' root location). Could this be an issue? I tried disabling it but it seems to have no effect.

    I also noticed it prepends the /nfs/c10/h01/mnt/123456/domains/ thingy. Is this normal? The "123456" is refering to my gridserver account number on Mediatemple. [ed. note: glidiasrage last edited this post 14 years, 3 months ago.]
      • 3749
      • 24,544 Posts
      Did you run Setup after moving the site? That will usually straighten out the paths. I'd also recommend turning off Friendly URLs if they are on and renaming the .htaccess file to ht.access before moving the site. That will remove one possible cause of trouble.


      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 40118
        • 10 Posts
        I did renamed my .htaccess back to ht.access.

        I tried to run /setup/. But when i get to the "action-options" location after the "action=welcome" page, i get a blank screen.

        For a fresh install folder location i did up (ie. modx/setup/), i don't get blank screen for "action=options".

        Is it possible to do a fresh install, than dump all tables in the database and re-put all tables and components back? Otherwise, i'll have to re-setup everything from scratch, which would be quite troublesome. [ed. note: glidiasrage last edited this post 14 years, 3 months ago.]
          • 3749
          • 24,544 Posts
          See if anything here helps: http://bobsguides.com/modx-troubleshooting.html.

          I would first try turning off the compress_css and compress_js System Settings. You can do it in the source site before moving it, or do it in the DB with PhpMyAdmin (in the modx_system_settings table).

          Then delete all files in the core/cache directory and clear your browser cache and cookies before running setup.


          ------------------------------------------------------------------------------------------
          PLEASE, PLEASE specify the version of MODX you are using.
          MODX info for everyone: http://bobsguides.com/modx.html
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 40118
            • 10 Posts
            Finally managed to get setup options to work after double-checking 'path' setting in modx_workspaces, which apparently was blank even though i remembered setting it earlier.

            Apparently, i had to also manually prepend the 'nfs/c10/h01/mnt/123456/domains/' to all my path settings, otherwise it can't detect the presence of the directory on the server during setup. For $http_host, should I be using s123456.gridserver.com or should i use the staging.xxx.com, because right now, i'm using s123456 url which points to the default website location on Mediatemple (ie. not the modx site hosted on the staging subdomain).
              • 3749
              • 24,544 Posts
              I'm afraid I don't know how to answer that one. Maybe someone else can help.


              ------------------------------------------------------------------------------------------
              PLEASE, PLEASE specify the version of MODX you are using.
              MODX info for everyone: http://bobsguides.com/modx.html
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting