We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38248
    • 5 Posts
    I upgraded from 2.2.0-pl2 to 2.2.4-pl.

    Before upgrading, I cleared site cache and logged out. I uploaded the zip folder via cPanel, unpacked it, and ran the setup using the upgrade option. Everything was checkmarked "ok" in the summary (no error reported).

    Issue 1:
    At my first login attempt with Firefox, the backend didn't seem to read the CSS and only outputted text. I tried refreshing the page and clearing browser cache, but to no avail. Same symptom on Chrome, except that refreshing the page pulled up the backend UI (albeit without the left navigation, and with nothing else working).

    Issue 2:
    I also get a "syntax error: Internal server Error" message which I have never seen (please see screenshot: https://dl.dropbox.com/u/994528/MODX/MODX%20Manager.PNG).

    All in all, the backend is unusable. At least the frontend works.

    Info on our hosting environment:
    OS: Linux
    Apache version: 2.2.22
    PHP version: 5.3.13

    Thanks in advance for any insights on troubleshooting. [ed. note: jeremyk last edited this post 14 years, 3 months ago.]
      • 38248
      • 5 Posts
      Update:

      I contacted our hosting provider (Green Geeks) after hitting the wall, and as it turns out, the backend (although plain vanilla) caused us to frequently max out on our allotted 512 Mb RAM (thus causing the 500s).

      We upgraded to 1Gb RAM on another server and all of the problems cited above have disappeared. The UI now loads much faster (and no more missing left sidebar or text-only display).