I'm including the main error in the title so that anyone searching for this specific failure can find this thread.
That account could not be located. Check the username and re-type the password to try again.
Here's the scenario. This is not the first time I've had this message and problem, last time I did the upgrade / test process I had the same issue, i was hoping that 2.2.2 had fixed it, but no such luck.
Problem comes when importing remote live db to local dev box db,
http://rtfm.modx.com/display/revolution20/Moving+Your+Site+to+a+New+Server
following basically that procedure. This used to work alright on the first modx revolution upgrades I did, now it's not working.
So, here's the steps: export db with dump on live remote server, after clearing the cache. Note, when I went back in and tried to also clear session, I get this error:
security -> flush all sessions -> flush_sessions_not_supported
Not encouraging. So I did a basic simple logout, then shut the browser then did the db dump, then downloaded the dump sql file, and imported it to my local db, which was working fine previously, running the version of the site from the last local/remote sync.
This is to prepare for the 2.2.2 to 2.2.4 upgrade, a process that should, for me, as a paid developer, take no more than 60 minutes. Last time took about 8 hours before this issue went away, no idea what made it finally vanish, but finally it let me login.
Before I go further, please resist the urge to suggest resetting the password, that is not the problem, the problem is somewhere else, and I am posting to find if that problem is fixable, or if I have to give up on modx, since I cannot rationalize to myself spending stressful unpaid hours every time I do a cms upgrade, except that it was me who recommended modx to client, so I am somewhat obligated to stand by the software, at least until it gets just too intolerable to do, which is very close right now, unless I can find a solution.
Last time I did a variety of things on my local system to try to fix it, the obvious, clearing browser cookies, restarting browser, clearing brorwser cache, trying alternate browsers, all kinds of things, and at some point one of them worked. No idea why.
This is MODX Revolution 2.2.2-pl (advanced)
We use the option to store sessions in file location, not db.
This method works and has worked on all versions once I get past the upgrade bumps.
Local system is debian linux
apache 2.2.22
php 5.4.3-5
mysql 5.5.23
remote live site is freebsd 7
apache 2.2.22
php 5.3.13
mysql 5.0.8
I used to keep the local server closer in version with php 5.3 and mysql 5.1, but when this happened last pre upgrade db import on the dev server, failure to accept login for admin user on manager, as a last ditch desperate attempt to try anything to fix it, I upgraded apache, php, and mysql. Didn't work, but it did for some unknown reason finally let me login again an hour or so later, after a few apache restarts and various random other things, different browser finally let me in that time.
Clearly it would be highly desirable to delete the sessions as well as the cache prior to doing the mysql dump to create the file to be imported, but since that part does not work in the remote site, failing with that above error message, that avenue is gone.
To me, it's beyond worrying that the programming could fail to send a user name and password to the database for checking, then return an error message that the username does not exist, then, after you do something or other, pray, try 5 different browsers, it suddenly works. This indicates to me a serious lack of robustness in that core logic, I can't say if it's in the session handling, in the ajax, or what, but clearly sending two text strings to a database for it to check should result in a returned value of a successful login, or a failed login with some message like, you are already logged in (if it's some type of session handling error that is).
While I like modx, and the the way it handles templates and snippets, I am allegedly a professional who also allegedly does this work for money, ie, it's my job, and having these kinds of weird issues that are basically impossible to track down makes me wonder if I should just bite the bullet and tell the client that sorry, we have to move to a more robust cms, not something I want to do, not something the client wants, i'll tell you that, modx really solved our issues very neatly, very good search engine friendly url handling, very nice snippet handling, but the inconsistency and consistent lost time I am getting on these upgrades is really starting to worry me.
My first choice is to solve this direct problem, and then move on with modx, and live with the occasional glitches, but if I can't even import a remote db, do the proper path changes in it, then login back in, a task that should take me no more than about 4 minutes total without losing an entire day each time it happens, I just dont' see how I can keep running modx.
By the way, the cause of my deciding to start the upgrade process was another old bug resurfacing on the live modx, an office admin reported a looping page add submit sequence (the updating dialogue just keeps repeating ... saving page then skipping back), something I'd noted the day before too when saving a page, though mine actually went through. This was a degradation, the site had been running decently well before that, especially once we pinpointed the huge page load slowdown to using live wayfinder menuing on the cached pages, after we fixed that, caching actually worked right, and was very quick.
Sorry for being verbose, but if you see this from my perspective, each time now I am settling down to do an upgrade, I set my timer, start it, then this time, hit the same bug as last time, and start watching my hours dribble away, unpaid, and it's certainly no fun for anyone involved, so if there is a solution, great, let's figure it out, and have this thread be a fix that people can find and point to, if there isn't, well that's something I need to know too.
In a sense I could throw caution to the winds and just apply the upgrades live on the remote live server, and not test them at all, but I think that's horribly irresponsible for me to do, and since I've already suffered one upgrade issue with revolution in the past that knocked off entire live contents until we figured out to set a switch in the manager for some friendly url thing that didn't need to be set on my local server (worrying in itself there too), I really can't trust an untested live upgrade. Though last time, I did note that the remote site upgraded just fine in the end, took very little time, and it was all fine.
But that is just so risky to do, it's a real site, with real traffic, and doing that is in my opinion not very professional on my part.
Any ideas or suggestions appreciated, but I want to note, when this happened last time, eventually something clicked somewhere, and, using a different browser, I was finally able to login to the local site with the imported remote db, but the total randomness of that event is very worrying. So it's not an issue with resetting passwords or any such thing, there's something that gets stuck somewhere unknown, that the remote db is looking for on the local system, but that something appears after a while if you do the right things to get unstuck, randomly.
I waited, by the way, 24 hours to post this, in case something was just stuck in sessions or something else. I'm using a dedicated firefox session and clearing cookies, as well as testing on other browsers, so if this is a session issue, then the way modx is handling sessions is so irregular and unpredictable it worries me, to be honest. And besides that, when you submit a form to a database to login, the sessions should not interfere with such a simple event. Which suggests that the event is not in fact simple at all. I've done enough hacking on phpbb login stuff to have a decent idea of what this code should be like, and there's no place for such a failure in it that I can think of, but modx code is another story, I don't have any familiarity with it.
I've generated a step by step copy and paste set of steps to avoid error for the upgrade procedure, along with all the other steps to do to try to avoid error, it's getting very long, but I'm still not able to get reliable upgrades and db syncs, for example now, the only way I can get back into my local modx dev site is to restore the db from backup, dump all the sessions, and hope I can login again, that's what I did last time, a few times, before the db import finally worked and i could login.
[ed. note: lizardx last edited this post 14 years, 3 months ago.]