The first thing to check is the paths in core/config/config.inc.php.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
I had same error right after installation. I solved it by looking in actual file on line 484. On line 483 there is a link to a file:
/core/model/modx/modx.class.php
This file was there but empty in my directory, I think FTP went wrong or something. I uploaded it again from the original software, and after it worked!!!