We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 39117
    • 20 Posts
    Running the setup after updating from v 2.1.1 to v 2.2.4 I got this error message.

    Fatal error: Class 'modX' not found in /is/htdocs/ ... /setup/includes/modinstall.class.php on line 484


    Any clue where I should start to find the error??


    php 5.3, mysql 5.1.61
      • 3749
      • 24,544 Posts
      The first thing to check is the paths in core/config/config.inc.php.



      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 46779
        • 1 Posts
        I had same error right after installation. I solved it by looking in actual file on line 484. On line 483 there is a link to a file:


        /core/model/modx/modx.class.php

        This file was there but empty in my directory, I think FTP went wrong or something. I uploaded it again from the original software, and after it worked!!!