Maby some more info will make someone check this out.
Web Server:
*PHP Version 5.3.2-1 (suexec)
* Apache
* ubuntu4.15
Database:
* MySQL version 5.1.62-0ubuntu0.10.04.1
* no tables over 1MB in size
MODx:
* Version MODX Revolution 2.2.4-pl (traditional)
* Updated from 2.2.2.tot.2.2.3 to 2.2.4
* Instaled Snippets: Archivist, Breadcrumbs, EventsX, FileLister, FormIt , Gallery, getPage, getResources, Login, MetaX, phpThumbOf , selfLink ,tagLister, UltimateParent ,Wayfinder
* Instaled Plugins: idem
All latest verslons.
snipppets in templates: EventsX, FileLister, getPage, getResources, phpThumbOf , selfLink , tagLister, UltimateParent , Wayfinder
Browser/Client:
* Chrome and safari both
* Mac osx snowlion
Problem:
Errorlog is not emptying, chuncks and templates are not saving, dialogs say it is succefull, but next time opening any chunck or template is like it was before.
What i did:
Started out with 2.2.2
Under 2.2.3 after update (all went well) these notices began to show.
Notice: Undefined index: tag in my basepath
/web/core/cache/includes/elements/modsnippet/33.include.cache.php on line 44
getResourceTag needed /?tag= in the url, before it worked without this /?tag= . The blog is build exactly like the blog example in
http://rtfm.modx.com/display/revolution20/Creating+a+Blog+in+MODx+Revolution
Solved this by making another page with getPage for the blog homepage,
blogs tags now link to the other one page with getResourceTag.
before it was working like the example with only one bloghome with getResourceTag.
So Solved but not really
While working with filelister i got this one:
Notice: Undefined variable: scriptProperties in my basepath
/core/components/filelister/model/filelister/filelister.class.php on line 124
Al in all i ended with just deleting this line of code in filelister.class.php to make it disapear.
/**
]if (!$this->modx->getOption('filelister.allow_root_paths',$scriptProperties,true)) {
$path = ltrim($path,'/');
}
So Solved but not really
Next i installed 2.2.4, No errors while installing.
redirecting to the login an an old bug showed it self. All css gone, java not working, Superuser no rights etc. Solved this by removing cookies from browsers and removing all cache files.
See related post:
https://forums.modx.com/thread/73120/revo-2-2-0-pl2-traditional-bug#dis-post-424537
So Solved but not really (again!)
Next prob , keep getting worse every update *-(
Error log is not emptying, chuncks and templates are not saving,
dialogs say Succesfull! but next time opening on of these and everything is like it was before the save.
Anyone got any clue what is going on here?
[ed. note: hurby last edited this post 14 years, 3 months ago.]