Starting with MODx revo 2.2+ I have noticed a number of strange things happening in MODx manager. Because I have a couple of tweaks and nobody else seemed to notice similar issues I thought it was related to one of my messy fixes.
Recently I have installed two new instances (revo 2.2.3, revo 2.2.4). Both of them are unmodified, but the same problems showed up:
1. The tree is "forgetting" subresources. So there is no arrow to click on. I know I have chunks, but they don't show up. Refreshing the tree as well as hitting F5 helps in most cases.
2. The Manager is trying to load the frontpage inside an ifame. This happended inside the content area as well as inside modal windows (see attached MODx Error - Error with homepage content.png).
3. I get nasty error messges:
Unexpected token <:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
This is what Chrome developer tools are logging:
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://example.com/connectors/element/index.php?action=getNodes&id=n_type_template&type=template
Could not send response: Cannot send a response more than once per chrome.extension.onRequest listener per document (message was sent by extension cpngackimfmofbokmjmljamhdncknpmg). miscellaneous_bindings:142
Erro 500 explained a lot so I had a look at log files and other things.
I habe a tool on my server logging resources consumption. Please have a look at the attached "resources usage overview.png".
It tells us that I sometimes hit 1.5 GB of RAM and 100% of CPU usage (I have 2 cores).
After some research I found out, that I can do this simply clicking on a chunk or snippet:
From: 06-17 15:06 To: 06-17 15:07
CPU Usage:
average: 41
maximum: 100
Connections (different IP)
avarege: 2
maximum: 6
available: 35
Memory Usage
average: 187.5M
maximum: 1.5G
available: 1.5G
Number of times application hasent been able to execute due to memory limit
No: 2
These numbers relate to all processes going on for a particular account per millisecond. So hitting F5 and then hitting it again a second later woud not cause this behaviour.
A look at awstats showed up other intersting details (data from June 2012):
500 Internal server Error: 21 hits
404 Document Not Found (hits on favicon excluded): 14 hits
401 Unauthorized: 9 hits
301 Moved permanently (redirect): 8 hits
302 Moved temporarily (redirect): 5 hits
Thats an awful lot of errors for a page that only consists o a manager an a few frontpages.
I'm not sure, but i think this is related to the resources tree, because most of the time the content is loaded quite fast, as soons as the the tree ist starting to update the whole manager goes BOOM...
Some data for my hosting environment.
Subdomain in a reseller shared hosting
php Version 5.2.17
MYSQL Version 5.0.95
max mem 60 MB
max execution time 60 sec.
what gives ma a headache is the fact, that i can't reproduce this behaviour. It just happens from time to time.
I can post more info or give an account login to anyone interested.
Regards,
pepebe
[ed. note: pepebe last edited this post 14 years, 3 months ago.]