We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38106
    • 21 Posts
    Hi all,

    So I'm having a pretty frustrating installation issue.

    I'm currently expanding our current modx setup to include multiple load-balanced servers.

    However, I'm having trouble installing modx on the newest server.

    I've copied over all the files and duplicated the db just fine. The files have the correct permission settings (same ones as the other servers) however I'm still running into a 500 (internal server error) issue.

    When I run setup and connect to a DB correctly, nothing happens when I click the "Test database server connection..." link. In the console, it shows that POST to '../setup/processors/connector.php' is returning a 500 error. When I try to correct to a wrong DB, it gives me the standard red error message.

    I'm sure that it's not a DB issue because I can connect to the MySQL server just fine from the terminal.

    I believe its an issue with how PHP and/or Apache have been installed.

    I vaguely remember running into this issue before, but I have no idea how I solved it.

    I think I may need to change some PHP/Apache settings or install a mod or two.
      • 38106
      • 21 Posts
      Anybody?
        • 38106
        • 21 Posts
        Still working on this.
          • 38106
          • 21 Posts
          Still working on this.
            • 38106
            • 21 Posts
            Still working on this.
              • 39521
              • 15 Posts
              +1 I'm getting this same error.. I can't continue installation because it's throwing this server error.
                • 38106
                • 21 Posts
                Make sure that $database_dsn in core/config/config.inc.php matches the rest of your db settings.
                  • 39521
                  • 15 Posts
                  I don't have a config.inc.php yet. the installation hasn't been completed.
                    • 27708 MODX Staff
                    • 2,502 Posts
                    mstank, this could be permissions on the files or the files may not be there. If you were moving from one server to another and had it previously installed on another server, you should have a config.inc.php file from the original server and would only need to follow these instructions in a move. That being said you shouldn't be getting a 500 which leads me to believe there is something else wrong. I'd check your php error log on the server if you have it. I'd also suggest reuploading all the modx files from a fresh download and try set up again.
                      Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub