Does the WSOD go away when you manually delete all files in the core/cache directory?
Also, in my experience, the WSOD is most often caused by a plugin with an error in it. If E_NOTICE is on, newer versions of PHP will throw an E_NOTICE warning every time an undefined array index is referenced, which is fairly common in the code of many extras. That seems to crash MODX (though it probably shouldn't). The sites where it's working may have E_NOTICE off.
One way of diagnosing things is to temporarily set the 'disabled' field of plugins, one at a time, in the modx_plugins table and see if the problem goes away.
Also, looking at your error log, another possible explanation might be that the host has implemented suPHP or something similar and you need to change the permissions on the core/cache directory (and maybe other directories as well).
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
[ed. note: BobRay last edited this post 14 years, 2 months ago.]