We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 35517
    • 2 Posts
    It takes upwards of 90 seconds to load the MODx manager each time it's opened.

    I checked Safari's activity log and the following paths seem to be causing the delay:
    http://65.162.94.76/manager/index.php?a=1&f=nodes&indent=1&parent=0&expandAll=2
    http://65.162.94.76/manager/index.php?a=2

    Once loaded, everything runs quickly and smoothly. What's going on?

    Additional Details
    Evolution 1.0.6
    Microsoft-IIS/7.5
    PHP Version 5.2.17
    Plugins have been added, but the slowness occurred fresh out of the box [ed. note: modworldwide last edited this post 14 years, 3 months ago.]
      • 4041
      • 788 Posts
      Not sure about IIS server, but maybe try removing the 2 rss feeds in the configuration.

      Top menu - Tools / Configuration /

        xforum
        http://frsbuilders.net (under construction) forum for evolution
        • 36404
        • 307 Posts
        hi,

        i was about to say the same as breezer, some server are very slow to retreive the rss feeds, i recently had the same issue and deleting the two feeds made things normal again

        i would just add a little thing, if you only empty the two rss links in the config you manager will throw errors (not visible if not in a debuging tool but it's never a good thing)
        in order to have it work without errors you should comment those lines (as shown)
        // include rss feeds for important forum topics
        /*
        include_once "rss.inc.php"; 
        
        // modx news
        $modx->setPlaceholder('modx_news',$_lang["modx_news_tab"]);
        $modx->setPlaceholder('modx_news_title',$_lang["modx_news_title"]);
        $modx->setPlaceholder('modx_news_content',$feedData['modx_news_content']);
        
        // security notices
        $modx->setPlaceholder('modx_security_notices',$_lang["security_notices_tab"]);
        $modx->setPlaceholder('modx_security_notices_title',$_lang["security_notices_title"]);
        $modx->setPlaceholder('modx_security_notices_content',$feedData['modx_security_notices_content']);
        */
        

        in manager/actions/welcome.static.php (line 87)
        and these
        		<!-- modx news
        		<div class="tab-page" id="tabNews" style="padding-left:0; padding-right:0">
        			<h2 class="tab">[+modx_news+]</h2>
        			<script type="text/javascript">tpPane.addTabPage( document.getElementById( "tabNews" ) );</script>
        			<div class="sectionHeader">[+modx_news_title+]</div><div class="sectionBody">
        				[+modx_news_content+]
        			</div>
        		</div>	
        
        		<!-- security notices
        		<div class="tab-page" id="tabSecurityNotices" style="padding-left:0; padding-right:0">
        			<h2 class="tab">[+modx_security_notices+]</h2>
        			<script type="text/javascript">tpPane.addTabPage( document.getElementById( "tabSecurityNotices" ) );</script>
        			<div class="sectionHeader">[+modx_security_notices_title+]</div><div class="sectionBody">
        				[+modx_security_notices_content+]
        			</div>
        		</div>
        

        in assets/template/manager/welcome.html (line 54)
        as you can see just unclose the two comments will do the job

        then your manager will be happy and won't throw errors anymore smiley

        have swing
          réfléchir avant d'agir
          • 28439
          • 222 Posts
          You don't have to delete any code, to disable the news feeds.

          Open the configuration (Tools->Configuration), click on tab Site, scroll down to the bottom.
          There you find two fields for the RSS feeds, just empty them and it doesn't load the RSS feeds from now on.
            Gone away and found a better place to stay
            • 36404
            • 307 Posts
            Hi Stefanie,

            yes, you're right, but, as i said, doing just this throws debugging errors each time you open the manager homepage as modx keeps looking for feeds even if the fields say they're empty (you can see the errors in the events log and, if i remember well, in the tabs if you don't hide them before commenting the php lines)

            (forgive me, i must admit i'm quite a fussy fanatic when it comes to php/js errors smiley)

            have swing
              réfléchir avant d'agir
              • 28439
              • 222 Posts
              I do a ticket for this, it should be possible, to disable RSS feeds.
                Gone away and found a better place to stay
                • 28439
                • 222 Posts
                Just to mention this, the Japanese community did it the same way, as I would have done it.
                See Disable RSS feeds in the manager and welcome.static.php, line 135 and following.
                  Gone away and found a better place to stay
                  • 36404
                  • 307 Posts
                  hi Stefanie,

                  that's a more elegant way to do this when you want to keep the possibility to get rss feeds but honestly i took the opportunity to get rid of revo news in my managers smiley
                  (to be continued on git...)

                  have swing
                    réfléchir avant d'agir