We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36675
    • 56 Posts
    On Revo 2.2.2
    All server conditions satisfied

    While creating a new Access Control List for Editor users, the site suddenly became unavailable to everyone but myself, the super admin. Not even my publishing users were able to see the site online anymore.

    Since I have yet to grasp the ACL, Context, Role, Resource Group things yet, do you think there was a setting I touched there that made the whole site unavailable to the public?

    Or can it be related to two error messages from my host's apache log?

    From core/components/wayfinder.class.php line 340:
    $placeholders[$tvName]=$resource[$tvName];


    From core/components/gallery/elements/tv/input/galleryitem.php line 35:
    $item = $modx->getObject('galItem',$data['gal_id']);


    All help greatly appreciated!

    This question has been answered by jorgeca. See the first response.

    • discuss.answer
      • 36675
      • 56 Posts
      Luckily I found the reason pretty quick. The reason was wrongly configured resourcegroups.

      I created an AllPages resourcegroup for the Admin usergroup in the WEB context, without adding users not logged in. Subsequently everyone but the Admin usergroup where unable to view the page.

      The sollution seems pretty simple. I am creating resourcegroups for the MGR now.

      AllPages for the Admin usergroup
      MostPages for the Publisher usergroup
      OnePage for a specificed content Editor usergroup

      I think I got it figured now. But please let me know if you think some of this sounds fishy.