We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16348
    • 64 Posts
    Hi

    I have a site hosted at Site5 that has been up and running for approximately 6 months. The site is for a running event and I have some custom db-tables to manage entries to the race. All results from previous years are stored in one table and I use a custom snippet to retrieve these results together with personal data from the user profiles. Each year is shown on a different resource via the same snippet and a parameter which tells the snippet what year to retrieve.
    For some days ago, I found out that some of the resources gave a 404-error. It seems to be the resources that retrieves the most amount of rows from the database that has stopped working.

    My error log is empty, at least from things that can be related to this.

    Together with the support from Site5 we have increased the max_execution_time, max_input_time and memory_limit in php.ini with no luck. In the server error log, this message is shown: Premature end of script headers: index.php

    I tried to upgrade modx from 2.2.0pl2 advanced to 2.2.2pl advanced to see if that helped. In the setup-process, after the configuration check in the beginning, I got the same error (404). I couldn't go through with the upgrade the normal way. By manually extracting the core.transport.zip and then run the CLI-advanced upgrade I managed to finish the upgrade. This did not solve the problem.

    A live page that doesn't work is http://www.prinsensminne.se/efter-loppet/resultat/resultat-2009.html and a page that should work is http://www.prinsensminne.se/efter-loppet/resultat/resultat-2006.html.

    PHP version: 5.3.8
    MySQL version: 5.1.62-rel13.3-log
    MySQL client API version: 5.0.96

    Does anyone have any ideas where I should troubleshoot this? The snippet itself can most certain be more optimized but it has worked before and I haven't changed it for quite some time and as I said, I got the same problem with the modx setup script.

    Best regards
    Kristoffer
    [ed. note: Kristoffer last edited this post 14 years, 4 months ago.]
      • 16348
      • 64 Posts
      I have tried to sort out my problem with no luck. The problem with script termination is also happening on a custom post-hook to FormIt. There is still no errors in the modx error log.
      I have "re-upgraded" my installation to modx 2.2.2pl-advanced in case there were some corrupt files but it didn't helped. This time I didn't try the normal setup, instead I used the CLI-setup direct.
        • 16348
        • 64 Posts
        I'm totally out of ideas how to troubleshoot this matter. The problem seems to be that some snippets by some reason terminates in a way that modx handles the termination as a 404-error. There is no error messages displayed in the modx error log or in the server log (according to my host).
        Is it possible to write a plugin that catches the reason that the 404-page is shown?
        Is it possible to get some more error messages out of xpdo?
        Is the error caused by modx or is there some fault at Site5 (my host)? What should I say to the support at Site5 to get them to look in the right direction?
        Any other ideas?

        Thanks in advance
        Kristoffer