I think there is a System Setting that controls which hash method is used. You might have to set it to MD5 for the password to work.
If you tried the password several times, that might be why you're blocked. Normally, the block only lasts for an hour.
If all users are blocked (unlikely), this snippet would unblock them:
<?php
/* unblock all users */
$users = $modx->getCollection('modUser');
foreach ($users as $user) {
$profile = $user->getOne('Profile');
if ($profile) {
if ($profile->get('blocked')) {
$profile->set('blocked', '0');
}
$profile->save();
}
}
[ed. note: BobRay last edited this post 14 years, 4 months ago.]
Oh, nice little snippet Bob. Ya, they are blocked as soon as I import them into revo. I can't figure out why, but your snippet should help. Let me see if I can get the pw working via settings and kill the blocked issue via your snippet.
If that all works, I am still left with having to right-click import 700 members. It may be my only option though. Thanks again, Bob.
I don't see anything, but I'm using my phone now.
Did you paste it or type it?
My bad, Bob. I am subscribed to the thread, but I never got an email that you replied. Here is the error message:
Parse error: syntax error, unexpected '{' in /home/deniro03/public_html/clients/test1/core/cache/includes/elements/modsnippet/11.include.cache.php on line 14
My bad, Bob. I am subscribed to the thread, but I never got an email that you replied. Here is the error message:
Parse error: syntax error, unexpected '{' in /home/deniro03/public_html/clients/test1/core/cache/includes/elements/modsnippet/11.include.cache.php on line 14
My bad, missing ')'. Fixed above.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
Damn, I should have caught that myself. Thanks.
Thanks, Bob. Your snippet works great, as Provisoner marks all imported users "blocked". It's bad enough that I have to right click and import each user, but this snippet will "unblock" all the imported users at once. I just put the snippet call in my main template and refreshed the users page in the manager and all we unblocked.
Thanks, again.
I'm glad it worked for you. Sorry about the error.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html