I've searched the Forums and Google, reviewed the server error logs but can't make sense of this issue: when adding a Ditto call to the Home page, the server throws a 500 error message. If we take out the Ditto reference, the page displays normally.
We've also reviewed that the IIS base path to the assets directory is correct, and tried both cached and uncached Ditto calls, with and without various Ditto parameters. We've built a chunk to display the Ditto results and tried calling it as a tpl parameter as well. Friendly URLs are off.
Since we usually deploy MODx on a LAMP server, I'm really at a loss... why should adding the Ditto call cause a server error like this, and how can we fix it?
Many thanks for any help!
[ed. note: marknow last edited this post 14 years, 4 months ago.]
Still searching... we're not used to IIS, so any help is really appreciated.
-
☆ A M B ☆
- 711 Posts
Hi,
I'm seeing this also on a customers site, from what i can see so far using Ditto within a chunk i.e.
{{mychunkname}}
-----
{{mychunkname}}
[!Ditto? &startID=`4` &summarize=`5` &tpl=`nieuws-slider-li` &showPublishedOnly=`0`!]
Causes Internal 500 errors on the page, but if you change the Ditto call within the chunk to
[[Ditto? &startID=`4` &summarize=`5` &tpl=`nieuws-slider-li` &showPublishedOnly=`0`]]
It works I'm still looking around at what the issue could be.
-
☆ A M B ☆
- 711 Posts
Just a quick update, We have just disabled PHX Plugin on the MODx site and now everything works fine without any Internal Server error I now need to find out why PHX is breaking the site.
Thanks Aaron